CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

SimpleFoam Error with librdmacm amp libibverbs

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 17, 2008, 17:21
Default Hi all, I am trying to run
  #1
New Member
 
Join Date: Mar 2009
Posts: 7
Rep Power: 8
dnomdec is on a distinguished road
Hi all,

I am trying to run simpleFoam (1.4.1) in parallel. When I ran in double precision, things seem to work OK. However, in single precision, I got the following error (on each processor I am running):

librdmacm: couldn't read ABI version.
librdmacm: assuming: 4
libibverbs: Fatal: couldn't read uverbs ABI version.
CMA: unable to open /dev/infiniband/rdma_cm
--------------------------------------------------------------------------
[0,1,0]: OpenIB on host hpcs01 was unable to find any HCAs.
Another transport will be used instead, although this may result in lower performance.

Does simpleFoam require different/extra libraries in single precision vs. double precision? I could find librdmacm.so, libibverbs.so and libmthca.so in /usr/lib. The funny thing is, I don't even have infiniband on my cluster.

I'm quite new to OpenFOAM, so any help is appreciated.

Thx!!
Ned
dnomdec is offline   Reply With Quote

Old   May 21, 2010, 08:02
Default Check the OFED version
  #2
New Member
 
sid
Join Date: May 2010
Posts: 1
Rep Power: 0
sidharth is on a distinguished road
Hi,

I had the same error.
The problem was due to the mismatch in OFED version and the kernel version.
Install the latest version of OFED and check if it supports the kernel version that you are using.
It worked for me.

All The Best!!!
Sidharth Kashyap
sidharth is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SimpleFoam error sven82 OpenFOAM Running, Solving & CFD 0 October 16, 2008 04:13
Error running simpleFoam in parallel skabilan OpenFOAM Running, Solving & CFD 2 August 29, 2008 09:42
SIMPLEFOAM ERROR ON A RAE2822 dinonettis OpenFOAM Running, Solving & CFD 0 April 28, 2008 09:50
Error message using simpleFoam plmauk OpenFOAM Running, Solving & CFD 0 January 22, 2008 08:46
SimpleFoam error message braennstroem OpenFOAM Running, Solving & CFD 1 October 15, 2007 12:33


All times are GMT -4. The time now is 01:08.