CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

SimpleFoam error message

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 15, 2007, 04:07
Default Hi, I am having some troub
  #1
Senior Member
 
Fabian Braennstroem
Join Date: Mar 2009
Posts: 407
Rep Power: 10
braennstroem is on a distinguished road
Hi,

I am having some trouble to run an optimization loop using simpleFoam. For this I created a base setup, which ran to convergence, and cloned the mesh/setup by 'cp -a base_case new_case'. Afterwards I imported a slightly different mesh from FLUENT. Everything seems fine, but when starting the run on the new case I get:
Selecting turbulence model RNGkEpsilon

Starting time loop

Time = 1

#0 Foam::error::printStack(Foam:stream&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#1 Foam::sigFpe::sigFpeHandler(int) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libOpenFOAM.so"
#2 __restore_rt in "/lib64/tls/libc.so.6"
#3 void Foam::fvc::surfaceIntegrate<foam::vector<double> >(Foam::Field<foam::vector<double> >&, Foam::GeometricField<foam::vector<double>, Foam::fvsPatchField, Foam::surfaceMesh> const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libfiniteVolume.so"
#4 Foam::tmp<foam::geometricfield<foam::vector<double >, Foam::fvPatchField, Foam::volMesh> > Foam::fvc::surfaceIntegrate<foam::vector<double> >(Foam::GeometricField<foam::vector<double>, Foam::fvsPatchField, Foam::surfaceMesh> const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libfiniteVolume.so"
#5 Foam::tmp<foam::geometricfield<foam::vector<double >, Foam::fvPatchField, Foam::volMesh> > Foam::fvc::surfaceIntegrate<foam::vector<double> >(Foam::tmp<foam::geometricfield<foam::vector<doub le>, Foam::fvsPatchField, Foam::surfaceMesh> > const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libfiniteVolume.so"
#6 Foam::fv::gaussDivScheme<foam::tensor<double> >::fvcDiv(Foam::GeometricField<foam::tensor<double >, Foam::fvPatchField, Foam::volMesh> const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libfiniteVolume.so"
#7 Foam::tmp<foam::geometricfield<foam::innerproduct< foam::vector<double>, Foam::Tensor<double> >::type, Foam::fvPatchField, Foam::volMesh> > Foam::fvc::div<foam::tensor<double> >(Foam::GeometricField<foam::tensor<double>, Foam::fvPatchField, Foam::volMesh> const&, Foam::word const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libincompressibleTurb ulenceModels.so"
#8 Foam::tmp<foam::geometricfield<foam::innerproduct< foam::vector<double>, Foam::Tensor<double> >::type, Foam::fvPatchField, Foam::volMesh> > Foam::fvc::div<foam::tensor<double> >(Foam::GeometricField<foam::tensor<double>, Foam::fvPatchField, Foam::volMesh> const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libincompressibleTurb ulenceModels.so"
#9 Foam::tmp<foam::geometricfield<foam::innerproduct< foam::vector<double>, Foam::Tensor<double> >::type, Foam::fvPatchField, Foam::volMesh> > Foam::fvc::div<foam::tensor<double> >(Foam::tmp<foam::geometricfield<foam::tensor<doub le>, Foam::fvPatchField, Foam::volMesh> > const&) in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libincompressibleTurb ulenceModels.so"
#10 Foam::turbulenceModels::RNGkEpsilon::divR(Foam::Ge ometricField<foam::vector<doub le>, Foam::fvPatchField, Foam::volMesh>&) const in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/lib/linux64GccDPOpt/libincompressibleTurb ulenceModels.so"
#11 main in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/simpleFo am"
#12 __libc_start_main in "/lib64/tls/libc.so.6"
#13 Foam::regIOobject::readIfModified() in "/home/gcae504/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linux64GccDPOpt/simpleFo am"
Floating exception (core dumped)

Like I mentioned just, just the mesh was changed by morphing, so no differences in any boundary condition or scheme. The imported mesh seems to be ok, at least an export back to FLUENT works well.

Does anyone have an idea?
Fabian
braennstroem is offline   Reply With Quote

Old   October 15, 2007, 12:33
Default Hi, it seems that I had some
  #2
Senior Member
 
Fabian Braennstroem
Join Date: Mar 2009
Posts: 407
Rep Power: 10
braennstroem is on a distinguished road
Hi,
it seems that I had some penetrations in the morphed mesh, sorry bothering you.

Fabian
braennstroem is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SimpleFoam Error with librdmacm amp libibverbs dnomdec OpenFOAM Running, Solving & CFD 1 May 21, 2010 08:02
SimpleFoam error sven82 OpenFOAM Running, Solving & CFD 0 October 16, 2008 04:13
Error running simpleFoam in parallel skabilan OpenFOAM Running, Solving & CFD 2 August 29, 2008 09:42
SIMPLEFOAM ERROR ON A RAE2822 dinonettis OpenFOAM Running, Solving & CFD 0 April 28, 2008 09:50
Error message using simpleFoam plmauk OpenFOAM Running, Solving & CFD 0 January 22, 2008 08:46


All times are GMT -4. The time now is 17:55.