CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Error when running SonicTurbFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 19, 2007, 02:29
Default Hello everyone, I was trying t
  #1
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 9
shaun is on a distinguished road
Hello everyone, I was trying to play around with the sonicTurbFoam tutes avaiable in OF 1.3 and got the reported error when I tried to run them (see below). I checked the controlDict file but everything seemed fine to me. What does this error mean please? Thanks for your time.

lads@PhantomWorks:~/OpenFOAM/lads-1.3/run/tutorials/sonicTurbFoam$ sonicTurbFoam . prism
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

debug::switchSet(const char*, dictionary*):
Cannot find DimensionedConstants in dictionary /home/lads/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/controlDict

lads@PhantomWorks:~/OpenFOAM/lads-1.3/run/tutorials/sonicTurbFoam$ ll
total 20
-rwxr-x--- 1 lads lads 192 2007-03-09 14:36 Allclean
-rwxr-x--- 1 lads lads 820 2007-03-09 14:36 Allrun
drwxr-xr-x 7 lads lads 4096 2007-04-19 16:17 nacaAirfoil
drwxr-xr-x 6 lads lads 4096 2007-04-19 16:22 prism
-rw-r----- 1 lads lads 483 2007-03-09 14:36 Running_Notes
lads@PhantomWorks:~/OpenFOAM/lads-1.3/run/tutorials/sonicTurbFoam$ sonicTurbFoam . nacaAirfoil
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

debug::switchSet(const char*, dictionary*):
Cannot find DimensionedConstants in dictionary /home/lads/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/controlDict

lads@PhantomWorks:~/OpenFOAM/lads-1.3/run/tutorials/sonicTurbFoam$
shaun is offline   Reply With Quote

Old   April 20, 2007, 02:38
Default OK, so I tried setting up my o
  #2
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 9
shaun is on a distinguished road
OK, so I tried setting up my own case using the sonicTurbFoam solver application and still recieved the same error as I originally posted.

Has anyone ever used the sonicTurbFoam solver app and recieved this error for OF1.3 release?

I checked that the debug switches in the controlDict file as specified above, but nothing seems out of the ordinary.

I need some help with this please.

Thanks for your time.

Regards

Shaun.D
shaun is offline   Reply With Quote

Old   April 20, 2007, 13:06
Default hi shaun, i tried the prism
  #3
Senior Member
 
Markus Hartinger
Join Date: Mar 2009
Posts: 102
Rep Power: 9
hartinger is on a distinguished road
hi shaun,

i tried the prism example with OF 1.3 and it's working fine. maybe try a good old reinstall

markus
hartinger is offline   Reply With Quote

Old   April 20, 2007, 19:11
Default Markus, thanks for the reply.
  #4
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 9
shaun is on a distinguished road
Markus, thanks for the reply. I was afraid it may come to that. I was hoping it was something simple, but I am afraid my knowldege of the OF code is still not completely adequate. It would be a blunt tool if I had to reinstall everytime something like this occurred. Perhaps I have no option.

Thanks for thinking about it.

Cheers

Shaun.D
shaun is offline   Reply With Quote

Old   April 25, 2007, 22:55
Default G'day, just writing to inform
  #5
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 9
shaun is on a distinguished road
G'day, just writing to inform the ladies and gents that after installing OF-1.4 I tested the sonicTurbFoam solver application and it is running.

Not sure what happened with my OF-1.3 installation.

Thanks to Markus for his reply.

Regards

Shaun.D
shaun is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
running CFX-RIF: error window jonathan CFX 10 December 19, 2007 13:08
ERROR IN RUNNING THE FIRST EXAMPLE marhamat OpenFOAM Installation 8 August 27, 2006 04:13
FIDAP RUNNING ERROR "ERROR-DIR-NOT-EMPTY=145" BAOYU FLUENT 0 January 26, 2006 19:32
DPM running error! x.p.lee FLUENT 0 July 3, 2003 05:44
error while running UDF murthy FLUENT 1 October 22, 2001 05:02


All times are GMT -4. The time now is 22:51.