CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Running paraFoam on remote machine (http://www.cfd-online.com/Forums/openfoam-solving/59912-running-parafoam-remote-machine.html)

makh August 11, 2005 07:52

I installed and ran paraFoam a
 
I installed and ran paraFoam as in:
http://www.opencfd.co.uk/openfoam/li...tml#linuxAMD64

I also did the same on remote cluster but I recompiled the code using Allwmake. I ran the code no problem. But when I try to start paraFoam on the case result, I get the following error:

ParaView error: InitializeTcl failed
Tk_Init error: no display name and no $DISPLAY environment variable

If I try to run it from other node except the main one, I get the following error:

paraview: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

I tried to look for libGL.so, I could not find it neither on the remote nor local version that is still working.

Thanks,
Marwan

makh August 12, 2005 14:57

Problem solved.
 
Problem solved.

liugx212 January 2, 2006 21:31

Dear Marwan Khalil: Could you
 
Dear Marwan Khalil:
Could you please tell me how to solve this question? I also met the same problem. So please help me.

Thank you very much.
xiang

jmr December 4, 2006 05:12

hi@everybody i have also a
 
hi@everybody

i have also a problem with InitializeTcl when I try to start paraFoam or paraview. Shown IP is the correct IP of my local host. Wonder if somebody could help me....

thx, jmr

the error message:

ParaView error: InitializeTcl failed
Tk_Init error: Can't find a usable tk.tcl in the following directories:
/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4

/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl: can't access "::tk::Priv.::ffff:140.78.134.44:0": parent namespace doesn't exist
can't access "::tk::Priv.::ffff:140.78.134.44:0": parent namespace doesn't exist
while executing
"upvar #0 ::tk::Priv.::ffff:140.78.134.44:0 ::tk::Priv"
("uplevel" body line 1)
invoked from within
"uplevel #0 upvar #0 ::tk::Priv.$disp ::tk::Priv"
(procedure "tk::ScreenChanged" line 9)
invoked from within
"tk::ScreenChanged [winfo screen .]"
(file "/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl" line 277)
invoked from within
"source /home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $file]"


This probably means that tk wasn't installed properly.


All times are GMT -4. The time now is 16:45.