CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Running paraFoam on remote machine

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 11, 2005, 07:52
Default I installed and ran paraFoam a
  #1
makh
Guest
 
Posts: n/a
I installed and ran paraFoam as in:
http://www.opencfd.co.uk/openfoam/li...tml#linuxAMD64

I also did the same on remote cluster but I recompiled the code using Allwmake. I ran the code no problem. But when I try to start paraFoam on the case result, I get the following error:

ParaView error: InitializeTcl failed
Tk_Init error: no display name and no $DISPLAY environment variable

If I try to run it from other node except the main one, I get the following error:

paraview: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

I tried to look for libGL.so, I could not find it neither on the remote nor local version that is still working.

Thanks,
Marwan
  Reply With Quote

Old   August 12, 2005, 14:57
Default Problem solved.
  #2
makh
Guest
 
Posts: n/a
Problem solved.
  Reply With Quote

Old   January 2, 2006, 21:31
Default Dear Marwan Khalil: Could you
  #3
Senior Member
 
Guoxiang
Join Date: Mar 2009
Posts: 109
Rep Power: 8
liugx212 is on a distinguished road
Dear Marwan Khalil:
Could you please tell me how to solve this question? I also met the same problem. So please help me.

Thank you very much.
xiang
liugx212 is offline   Reply With Quote

Old   December 4, 2006, 05:12
Default hi@everybody i have also a
  #4
jmr
New Member
 
joerg_m_reiter
Join Date: Mar 2009
Posts: 1
Rep Power: 0
jmr is on a distinguished road
hi@everybody

i have also a problem with InitializeTcl when I try to start paraFoam or paraview. Shown IP is the correct IP of my local host. Wonder if somebody could help me....

thx, jmr

the error message:

ParaView error: InitializeTcl failed
Tk_Init error: Can't find a usable tk.tcl in the following directories:
/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4

/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl: can't access "::tk::Priv.::ffff:140.78.134.44:0": parent namespace doesn't exist
can't access "::tk::Priv.::ffff:140.78.134.44:0": parent namespace doesn't exist
while executing
"upvar #0 ::tk::Priv.::ffff:140.78.134.44:0 ::tk::Priv"
("uplevel" body line 1)
invoked from within
"uplevel #0 upvar #0 ::tk::Priv.$disp ::tk::Priv"
(procedure "tk::ScreenChanged" line 9)
invoked from within
"tk::ScreenChanged [winfo screen .]"
(file "/home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl" line 277)
invoked from within
"source /home/reiter/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/tk8.4/tk.tcl"
("uplevel" body line 1)
invoked from within
"uplevel #0[list source $file]"


This probably means that tk wasn't installed properly.
jmr is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Distributed Parallel on dual core remote machine Justin CFX 1 February 3, 2008 18:23
Installation on IBM machine running AIX gellert OpenFOAM Installation 2 October 14, 2005 04:26
Running paraFoam on remote machine makh OpenFOAM Paraview & paraFoam 1 August 12, 2005 14:42
Run FOAM on a remote machine luckyluke OpenFOAM Installation 1 June 21, 2005 05:19
Remote running VENUGOPAL FLUENT 0 September 15, 2004 13:54


All times are GMT -4. The time now is 04:25.