CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   DNS Foam tutorial problem (http://www.cfd-online.com/Forums/openfoam-solving/60146-dns-foam-tutorial-problem.html)

msekandi1 June 21, 2006 07:05

Hi, I'm new to foam and I h
 
Hi,

I'm new to foam and I have a problem running the dnsFoam tutorial and the ChannelOodles tutorial. I can construct the mesh and the tutorial will run. However, when I try to load up paraview to look at the results I get the following error message:

--> FOAM FATAL ERROR : Not implemented

From function void CyclicPointPatchField<patchfield,>::evaluate ()
in file /home/dm2/henry/OpenFOAM/OpenFOAM-1.3/src/OpenFOAM/lnInclude/CyclicPointPatchFie ld.C at line 187.

FOAM aborting

/home/msekandi/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/paraview-real: symbol lookup error: /hom e/msekandi/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libOpenFOAM.so: undefined symbol: cplus_demangle



Any assistance would be much appreciated.

Regards,

Michael Sekandi

luca June 21, 2006 07:50

Hi Michael, Simply commen
 
Hi Michael,


Simply comments from line 183-187 in the file $FOAM_SRC/OpenFOAM/lnInclude/CyclicPointPatchFie ld.C

and recompile

Luca

msekandi1 June 21, 2006 09:31

Hi Luca, I tried this solut
 
Hi Luca,

I tried this solution but it failed and I got the same error message again.

I'm not sure what's wrong with the code.

Michael

luca June 21, 2006 09:51

Hi Michael, this is the rig
 
Hi Michael,

this is the right way. I have encountered the same problem.

See also http://www.cfd-online.com/cgi-bin/Op...=7286#POST7286

Luca

msekandi1 June 23, 2006 08:39

Hi, I have tried and tried
 
Hi,

I have tried and tried again, and still am encountering the same fatal error with ParaView for the dns and stressedfem tutorials. I think it's a path problem but I don't know what to do if it is.

Michael

hjasak June 23, 2006 13:27

Nope: you need to rebuild the
 
Nope: you need to rebuild the OpenFOAM library after you have done the stuff described above:

foamsrc
wmake libso

Enjoy,

Hrv


All times are GMT -4. The time now is 13:32.