CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

MPI error on Ubuntu 9.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 11, 2009, 05:37
Default MPI error on Ubuntu 9.04
  #1
New Member
 
Fabian Denner
Join Date: Mar 2009
Location: Zurich, Switzerland
Posts: 11
Rep Power: 8
denner is on a distinguished road
Hey OpenFOAM professionals,

a colleague of me runs OpenFOAM on a Ubuntu 9.04 VirtualMachine. If he likes to run his case parallel on local CPUs he get the following error message:

[0]
[0]
[0] Wrong number of arguments, expected 0 found 2
[0]
[0]
FOAM parallel run exiting
[0]
[VMUbuntu:04166] MPI_ABORT invoked on rank 0 in communicator MPI_COMM_WORLD with errorcode 1
mpirun noticed that job rank 1 with PID 4167 on node VMUbuntu exited on signal 15 (Terminated).





Does anybody know what's wrong?


Kind regards,
Fabian
denner is offline   Reply With Quote

Old   June 11, 2009, 07:56
Default
  #2
New Member
 
Fabian Denner
Join Date: Mar 2009
Location: Zurich, Switzerland
Posts: 11
Rep Power: 8
denner is on a distinguished road
Problem solved!
It has been a user error

Cheers, Fabian
denner is offline   Reply With Quote

Old   June 11, 2009, 08:46
Default
  #3
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Which virtual machine have you been using?

I tried VirtualBox from Sun, but this software is not able to address multiple CPUs from the host system so far.
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   June 13, 2009, 13:38
Default
  #4
New Member
 
Fabian Denner
Join Date: Mar 2009
Location: Zurich, Switzerland
Posts: 11
Rep Power: 8
denner is on a distinguished road
Hey sega,

you are right. He can't run in parallel.
Well no error occurs during decompose or when the solver is called. But he simply "distributes" the parts to the same CPU.

Cheers, Fabian
denner is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
qt4.3.4 with ubuntu 9.04 "jaunty jackalope"? sven OpenFOAM 4 May 30, 2009 18:22
Building OpenFOAM on IRIX lakeat OpenFOAM Installation 7 July 16, 2008 07:27
Error using LaunderGibsonRSTM on SGI ALTIX 4700 jaswi OpenFOAM 2 April 29, 2008 10:54
Is Testsuite on the way or not lakeat OpenFOAM Installation 6 April 28, 2008 11:12
Mpi problem with Ubuntu richard OpenFOAM Running, Solving & CFD 0 April 14, 2008 21:38


All times are GMT -4. The time now is 17:12.