CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Running in parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 3, 2009, 01:59
Default Running in parallel
  #1
New Member
 
sivakumar
Join Date: May 2009
Posts: 12
Rep Power: 8
s.sivakumar is on a distinguished road
Hello Foamers,
i am trying to run the simulation in parallel with two processor, after decomposition,
when i run mpirun, i am getting the following error,

--------------------------------------------------------------------------
Failed to find the following executable:

Host: localhost.localdomain
Executable: computerlist

Cannot continue.
--------------------------------------------------------------------------


can any one help me to overcome this problem?

with friendly,
sivakumar
s.sivakumar is offline   Reply With Quote

Old   July 3, 2009, 02:10
Default
  #2
Senior Member
 
Markus Rehm
Join Date: Mar 2009
Location: Erlangen (Germany)
Posts: 176
Rep Power: 8
markusrehm is on a distinguished road
Hi,

it is probably a missing machine file necessary for the mpirun. Have a look how it has to to be defined.

Regards, Markus
markusrehm is offline   Reply With Quote

Old   July 3, 2009, 10:16
Default hi
  #3
New Member
 
sivakumar
Join Date: May 2009
Posts: 12
Rep Power: 8
s.sivakumar is on a distinguished road
Hello Markus,
I got the solution for parallel running,
thank you for your reply.

with friendly,
sivakumar
s.sivakumar is offline   Reply With Quote

Old   July 4, 2009, 00:37
Default hi
  #4
New Member
 
sivakumar
Join Date: May 2009
Posts: 12
Rep Power: 8
s.sivakumar is on a distinguished road
Hello foamers,
i have run simulation with 2 processor, i think it is ok.
now the problem is, after finishing the calculation, I am trying to execute reconstructPar command, when i am executing reconstructPar i am getting the following error,
can any one help me overcome this problem.

[sivakumar@localhost windTunnelMPI]$ reconstructPar
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5.x |
| \\ / A nd | Web: http://www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Exec : reconstructPar
Date : Jul 04 2009
Time : 10:01:15
Host : localhost.localdomain
PID : 13571
Case : /volume/cfd4_shared/2009-ct-PI-004/OpenFOAM/sivakumar1.5.x/run/windTunnelCsae/windTunnelMPI
nProcs : 1

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Time = constant

No FV fields

No point fields

No lagrangian fields

End.

with friendly,
sivakumar
s.sivakumar is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
RSH problem for parallel running in CFX Nicola CFX 5 June 18, 2012 18:31
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52
User fortran error when running CFX-10 in parallel CFDworker CFX 2 October 26, 2007 16:01
running multiple Fluent parallel jobs Michael Bo Hansen FLUENT 8 June 7, 2006 08:52


All times are GMT -4. The time now is 03:44.