CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Running, Solving & CFD

problems with interPhaseChangeFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   November 17, 2009, 06:30
Default problems with interPhaseChangeFoam
New Member
Join Date: Sep 2009
Posts: 2
Rep Power: 0
utwaz is on a distinguished road
Hi there,

I am currently working on a NACA 0015 - hydrofoil and I want to simulate cavitation around it. I am using OpenFOAM 1.6 with the interPhaseChangeFoam-solver and as mentioned in another thread this is where the problems begin: The 'MULESImplicit'-syntax has changed but no matter what you do, it will not work (unless you try a work around as proposed by rickard bensow, which is to change 'MULESImplicit' to 'MULESExplicit'). So I'm using the explicit one at the moment but here is the next problem: After getting a converged wetted flow (by turning off cavitation in the beginning) my solution would diverge as soon as I try to get some cavitation. I raised the cavitation-coefficients gradually and paid attention to not overdo it, my Courant-number is below 0.5 as well, but after some hundred iterations something strange would happen: The residuals go below the tolerance value and due to that there are no more iterations for the pressure. This goes on for some time steps and I'll get a 'floating point exception' soon. After trying to restart the iteration with an older time step I will get the 'floating point exception' immediatly within the first time step.

I'm really stuck at this point and I would really appreciate any kind of help on this one.

PS: I don't see any strange effects in paraView, everything is looking really good and has some reasonable values.
utwaz is offline   Reply With Quote

Old   May 7, 2014, 06:25
Senior Member
Artur's Avatar
Join Date: May 2013
Location: Southampton, UK
Posts: 231
Rep Power: 6
Artur is on a distinguished road

I am getting exactly the same problem with my current simulation under OF 2.2.2. Have you figured out a solution to this?


Artur is offline   Reply With Quote



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Needed Benchmark Problems for FSI Mechstud Main CFD Forum 4 July 26, 2011 12:13
Some problems with Star CD Micha CD-adapco 0 August 6, 2003 13:55
unstructured grid sreekanth Main CFD Forum 1 August 6, 2001 15:09
Using Fluent for Geophysical Problems Hassid Samuel FLUENT 0 February 23, 2001 07:04
Inverse problems Aleksey Alekseev Main CFD Forum 0 May 12, 1999 15:38

All times are GMT -4. The time now is 03:54.