CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   No outflow - Error (http://www.cfd-online.com/Forums/openfoam-solving/70253-no-outflow-error.html)

sErik November 18, 2009 11:55

No outflow - Error
 
Hello everyone,

I'm trying to run my first own test case with OpenFOAM. I managed to snappyHexMesh my original .stl file.

Now I'd like to run simpleFoam on it. I adapted all the "0" and boundary conditions from the tutorials example for my case. But when I run simpleFOAM, I get following error:
__________________________________________________ _______________

Create time

Create mesh for time = 0

Reading field p

Reading field U

Reading/calculating face flux field phi

Selecting incompressible transport model Newtonian
Selecting RAS turbulence model kEpsilon
kEpsilonCoeffs
{
Cmu 0.09;
C1 1.44;
C2 1.92;
sigmaEps 1.3;
}


Starting time loop

Time = 1

DILUPBiCG: Solving for Ux, Initial residual = 1, Final residual = 0.0433399, No Iterations 1
DILUPBiCG: Solving for Uy, Initial residual = 1, Final residual = 0.077373, No Iterations 1
DILUPBiCG: Solving for Uz, Initial residual = 1, Final residual = 0.0489037, No Iterations 1


Continuity error cannot be removed by adjusting the outflow.
Please check the velocity boundary conditions and/or run potentialFoam to initialise the outflow.
Total flux : 7.34194e+06
Specified mass inflow : 9998.54
Specified mass outflow : 0
Adjustable mass outflow : 0


From function adjustPhi(surfaceScalarField& phi, const volVectorField& U,const volScalarField& p
in file cfdTools/general/adjustPhi/adjustPhi.C at line 116.

FOAM exiting
__________________________________________________ _______________

I don't know what to do now. I understand the problem, that there's no outflow, but where or how can I change that?

The boundary condition for my outlet is a patch, and all starting conditions are zeroGradient at the patch.

sErik November 18, 2009 12:10

All right :-)
I've just fixed the problem. I rechecked all files and then I saw, that the "p" condition wasn't correct at the outlet.
Let's wait for the results!


All times are GMT -4. The time now is 21:59.