CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   interFoam 1.6.x vs 1.5 : same mesh, same bc but different results (

nuovodna April 8, 2010 12:03

Water Flow around hull ship : interFoam 1.6.x vs 1.5
1 Attachment(s)
Hi, i simulated a flow around an hull ship with interFoam (only water, no air and free surface). I have results with v1.5 and they seems really good. I tried to repeat the problem setting up a complete similar case in v 1.6.x but it gives me bad pressure and velocity field (all force coeffs are wrong and the simulation stopped after two days giving me an error ). I d like to know the differences between v1.5 and v1.6.x and if i setted in the wrong way the different params of simulation. I attach a pdf with the principal files.

EDIT: contours of p and U here

g.redondo April 13, 2010 06:56

This is interesting. Anyone else facing this problem? Has anyone fixed it?

OF-1.6.x has some really nice features for hull analysis, but unless we figure out what is going on with the results they're useless.



g.redondo April 13, 2010 07:21

Having a look to your files I found a couple of things that might help, but still I don't think you'll get the same results.

1. In the inlet B.C I found that setting alpha to a constant value with setFields helps convergence.

2. You should also have an atmosphere patch.

3. Try with the hull as bouyantPressure too.

Good luck, although we're still missing something. I wish there was more documentation about interFoam in 1.6.x


nuovodna April 22, 2010 05:46

i think i have to change boundary condition on pressure : if in 1.5 i have zeroGradient, in 1.6.x i have to switch on buoyantPressure on the patch orthogonal to pressure gradient. I ll keep you updated on simulation's results. Stay tuned :)

nuovodna May 3, 2010 08:37

I changed the pressure boundary conditions and now p field seems good. But i have a local "dicontinuity" of U field on symmetry patch. How can i solve it?? I attach the screenshots

pablodecastillo May 4, 2010 05:34

Hi Emanuele,

That is because unstrured mesh (tetras) is not working nice.

Change your mesh to hexa and if possible structured and you will see everything better.

openfoam_user June 10, 2010 07:55

Hi Emanuele,

could you put your settings for OF-1.6.x ?

Have you improve your calculation ?

Best regards,


nuovodna June 14, 2010 05:27

2 Attachment(s)
I have set a less value of Courant number and now it works and it's running on 4 CPUs from two weeks :cool:

openfoam_user June 14, 2010 05:34

Hi Emanuele,

You have a very low Courant Number !

The wigley hull of Eric Paterson runs well with Courant Number 0.8.



nuovodna June 14, 2010 05:45

Do you think i have to investigate what are wrong in other part of the case?? I thought the mesh but checkMesh is perfect...any idea??

All times are GMT -4. The time now is 04:43.