CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

GLIBCXX_3.4.9 not found error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 25, 2010, 04:20
Default GLIBCXX_3.4.9 not found error
  #1
New Member
 
Pankaj Singh
Join Date: Jun 2010
Posts: 10
Rep Power: 7
Pankaj Singh is on a distinguished road
Hi,

I was able to successfully run and install OpenFoam 1.7.0 on my local machine (Suse 11.1)

I needed to run OF in parallel so i did a NFS mount of my local machine to a cluster with 16 processors (passwordless ssh).

But now when i give parallel run as suggested in OF-user guide, i get many errors, all saying same thing:

Code:
rhoSimpleFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by rhoSimpleFoam)
There are many such error statements but all complaining same thing: GLIBCXX_3.4.9 not found.

Further information:


Local machine: OF1.7.0 installed in this machine.
OS = Suse 11.1
gcc = 4.3.2
cmake = 2.8.2
Qt =4.6.2

Cluster:
OS = Red Hat Enterprise Linux ES release 4 (Nahant Update 6)
gcc = 3.4.6
cmake = command not found
Qt = 3.3.3

I get same error when i login to cluster and run OF on single processor (just to check if there is problem with parallel run alone).

Also, i was able to run OF in parallel with another machine (Suse 11.1), but problem is that machine has got just 2 processors.

Am struggling on this for past many days. Saw some forums about this error but am not sure really.

Any help will be greatly appreciated.

Regards
Pankaj
Pankaj Singh is offline   Reply With Quote

Old   September 26, 2010, 22:17
Default
  #2
New Member
 
Pankaj Singh
Join Date: Jun 2010
Posts: 10
Rep Power: 7
Pankaj Singh is on a distinguished road
Do i have to install OF on cluster??

But my cluster is RHEL4.x with pretty outdated stuff.

Cluster is used by many other users, so i think i will have to do some local installation of gcc/cmake/qt and many other stuffs. But am not sure how and what all is needed for that.

There is a thread for installation on RHEL5.x. Will that work for RHEL4.x?? I dont want to experiment with cluster as it is used by many other people. So would appreciate if someone who has already done it before can guide me.


Regards
Pankaj
Pankaj Singh is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CGNS Compiling Diego Main CFD Forum 17 December 21, 2014 02:40
Version 15 on Mac OS X gschaider OpenFOAM Installation 120 December 2, 2009 11:23
Installation OF1.5-dev ttdtud OpenFOAM Installation 46 May 5, 2009 02:32
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 04:43.