CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   attachDetach: Not all zones and patches needed in the definition have been found. (http://www.cfd-online.com/Forums/openfoam-solving/80911-attachdetach-not-all-zones-patches-needed-definition-have-been-found.html)

schmittp54 October 11, 2010 06:13

attachDetach: Not all zones and patches needed in the definition have been found.
 
Dear all,
I have set up a small test case to understand how to use the attachDetach dynamic mesh modifier. It is a simple cavity, where I attempt to insert a horizontal barrier by replacing the corresponding faces with boundaries. The case, which I am trying to run with OF1.5-dev, is attached.

The steps to run it are:
Quote:

blockMesh
faceSet
icoDyMFoam
However, the last steps fails with this error message:
Quote:

...
Not all zones and patches needed in the definition have been found. Please check your mesh definition.

From function void Foam::attachDetach::checkDefinition()
in file polyMeshModifiers/attachDetach/attachDetach.C at line 68.

FOAM aborting
I have found another post about this problem, with the recommendation to do what the error message says: make sure that all zones and patches are found. But I have checked that all patches are defined in blockMeshDict, and the faceSet "barrier" is also defined.
Please help me by running the attached case and suggesting where I have made a mistake.

Thank you very much
Patricia

jason_wy October 12, 2010 09:23

I didn't try your case. But my guess is you might need to do "setsToZones" to convert faceSet to faceZone.

Yi

schmittp54 October 20, 2010 09:26

Reposted as http://www.cfd-online.com/Forums/ope...achfvmesh.html because the initial error was solved, but other problems remain.

Hanno July 17, 2012 08:40

Solution??
 
Quote:

Originally Posted by schmittp54 (Post 279970)
Reposted as http://www.cfd-online.com/Forums/ope...achfvmesh.html because the initial error was solved, but other problems remain.

Would be nice to know how you solved it. Just "solved" is a pretty uselss answer in a support forum.

Cheers, Hannes.

panpanzhong June 5, 2013 16:31

Could you please post your case files? Thanks.


All times are GMT -4. The time now is 11:11.