CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Setup problem about overlapGgi (http://www.cfd-online.com/Forums/openfoam-solving/81336-setup-problem-about-overlapggi.html)

Ohbuchi October 24, 2010 09:20

Setup problem about overlapGgi
 
1 Attachment(s)
Dear all,

I'm trying to use overlapGgi.
I made simple mesh for testing overlapGgi as attached image.
The boundary file is as follows,

imp_out
{
type overlapGgi;
nFaces 160;
startFace 33240;
shadowPatch gui_in;
zone imp_out_zone;
rotationAxis (0 0 1);
angle 72.0;
bridgeOverlap false;
}
gui_in
{
type overlapGgi;
nFaces 136;
startFace 33104;
shadowPatch imp_out;
zone gui_in_zone;
rotationAxis (0 0 1);
angle 60.0;
bridgeOverlap false;
}

I wrote function "ggiCheck" in my controlDict, and ran the MRFSimpleFoam solver, then the solver showed following message.

Number of slave copies: 2
Evaluation of GGI weighting factors:

From function void GGIInterpolation<MasterPatch, SlavePatch>::rescaleWeightingFactors() const in file .../GGIInterpolationWeights.C at line 534
Uncovered faces found. On master: 8 on slave: 120
largest slave weighting factor correction: 0.0170587 average: 0.000617197
largest master weighting factor correction: 0.390019 average: 0.0196433

And calculation stopped in Time=1 before solving p-eq. for floating point exception.

I think my setting about overlapGgi is something wrong, but I can't make out how to modify it. What's the problem on my setting?
Any comments welcome.

Ohbuchi October 27, 2010 08:03

Re: Setup problem about overlapGgi (Fixed)
 
1 Attachment(s)
I've read source code "overlapGgiPatchFvPatch.H", and I've found that
master and slave patches must be started same edge.
So I change my mesh like attached image, and re-try simulation.
This time MRFSimpleFoam ran perfectly!

But this constraint (sharing same edge) is too hard to practical application,
I suppose.

aqua February 17, 2012 07:19

Quote:

Originally Posted by Ohbuchi (Post 280984)
I've read source code "overlapGgiPatchFvPatch.H", and I've found that
master and slave patches must be started same edge.
So I change my mesh like attached image, and re-try simulation.
This time MRFSimpleFoam ran perfectly!

But this constraint (sharing same edge) is too hard to practical application,
I suppose.

Hi, Good morning.
I know your post was there for a really long time. But, did you notice the tutorial case in 1.6-ext, "turboPassangeRotating" ? Because in that case the master and slave don't start at the same edge...

I currently have the problem that:
the solver doesn't complain about uncovered faces, but when I tried to use foamToEnsight, it complained about the "uncovered faces".

Do you know what maybe the problem?

Thank you so much!

Aqua


All times are GMT -4. The time now is 04:30.