CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   rhoCentralFoam with totalPressure/totalTemperature at inlet of subsonic channel (

deepblue17 October 26, 2010 15:10

rhoCentralFoam with totalPressure/totalTemperature at inlet of subsonic channel
2 Attachment(s)
I tried to run a very simple subsonic channel with rhoCentralFoam, with the following boundary conditions at the inlet:

p: totalPressure
T: totalTemperature
U: pressureDirectedInletVelocity

This gives me after a few iterations a very low pressure in the first cell layers, which is completely wrong, as I initialised the complete fields with the correct constant static solution. See the attached picture and case.

If I run the same case with sonicFoam I get my expected results.

Why is rhoCentralFoam not able to handle these combination of boundary conditions correctly?

vwibaut February 1, 2013 09:28


I re-activate this post cause I have the same problem. I want to simulate the flow in a nozzle and rhoCentralFoam gives a very wrong solution (and some times errors). Like deepblue17, I try to initialize with the correct solution but it also gives wrong solution.

Any idea about how to solve this problem?

Thanks a lot

immortality February 4, 2013 18:17

i have many problems with this solver.then ill go to sonicFoam if its more stable.

diwakaranant February 8, 2013 00:44

2 Attachment(s)

I am solving axisymmetric flow problem of flow between two rotating cylinders using rhoCentralFoam. I generated the mesh in GMSH and converted it into openFoam using gmshToFoam utility.
But when I am running the simulation, I am getting non-zero radial velocity
near the outer rotating cylinder, which ideally should be zero.

The Uy and the velocity vector plots near the outer rotating wall
are attached.

The axis of rotation is along X axis. Hence Uy is the radial velocity component.

Can some one tell why is this happening ?


immortality February 9, 2013 12:44

hi Valentin.did you find the solution of this problem or the cause of it?I have also this problem and continuity exploding with rhoPimpleFoam too(in simple scavenging or filling a closed end channel)

vwibaut February 11, 2013 03:42

No I doesn't find any solutions or cause to this problem. I will tell you if I have more informations about it.
Thanks to mention that there is also the problem with rhoPimpleFoam.

All times are GMT -4. The time now is 08:54.