CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   problem in ignition (http://www.cfd-online.com/Forums/openfoam-solving/90437-problem-ignition.html)

rajabiemad July 10, 2011 11:06

problem in ignition
 
Dear all!

a implimented the ignition code for the cylindrical domain for non-premixed flame and used the reactingFoam

duration of ignition is 0.001 s and the diameter of igniton is 0.02
i get the following error :
FOAM FATAL ERROR:
[0] attempt to use janafThermo<equationOfState> out of temperature range 200 -> 5000; T = 5000.26
[0]
[0] From function janafThermo<equationOfState>::checkT(const scalar T) const
[0] in file /home/emad/OpenFOAM/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude/janafThermoI.H at line 63.
[0]
FOAM parallel run aborting
[0]
[0] #0 Foam::error::printStack(Foam::Ostream&) in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/lib/linux64GccDPOpt/libOpenFOAM.so"
[0] #1 Foam::error::abort() in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/lib/linux64GccDPOpt/libOpenFOAM.so"
[0] #2 Foam::specieThermo<Foam::janafThermo<Foam::perfect Gas> >::H(double) const in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/lib/linux64GccDPOpt/libreactionThermophysicalModels.so"
[0] #3 Foam::ODEChemistryModel<Foam::psiChemistryModel, Foam::sutherlandTransport<Foam::specieThermo<Foam: :janafThermo<Foam::perfectGas> > > >::solve(double, double) in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/lib/linux64GccDPOpt/libchemistryModel.so"
[0] #4
[0] in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/reactingFoam"
[0] #5 __libc_start_main in "/lib/libc.so.6"
[0] #6
[0] in "/home/emad/OpenFOAM/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/reactingFoam"
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 7376 on
node emad exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).



please help me i want to remover this error


All times are GMT -4. The time now is 06:20.