CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

pisoFoam fails with locDynOneEqEddy

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 20, 2011, 11:27
Default pisoFoam fails with locDynOneEqEddy
  #1
Member
 
Join Date: May 2009
Posts: 51
Rep Power: 8
gfilip is on a distinguished road
pisoFoam crashes when I try to use the locDynOneEqEddy LES model.

libOpenFOAM.so and libincompressibleRASModels.so both show up in the attached log.

When I run the case with say dynSmagorinsky, everything works fine.


in my constant/LESProperties:

***************************************
LESModel locDynOneEqEddy
delta cubeRootVol;

locDynOneEqEddyCoeffs
{
ce 1.05;
filter simple;
}
****************************************

I have no issues with this turb model in a channel flow problem with both pisoFoam and channelFoam. I have checked the initial conditions several times but I cannot find anything that could be responsible for crash in this case.

Any hints are appreciated.
Attached Files
File Type: txt logRun.txt (28.1 KB, 16 views)
gfilip is offline   Reply With Quote

Old   December 29, 2011, 20:42
Default
  #2
Senior Member
 
Tarak
Join Date: Aug 2010
Location: State College, PA
Posts: 105
Rep Power: 6
Tarak is on a distinguished road
Hii,

You can try to solve this in 2 ways:

1. In the wall boundary condition for turbulent kinetic energy, give a very small value e.g 1e-20 instead of 0.

OR

2. Start solution using oneEqEddy or dynOneEqEddy model (or any other simpler model) and after some hundreds of iterations switch to locDynOneEqEddy model.

Thanks,
Tarak
Tarak is offline   Reply With Quote

Old   March 17, 2014, 12:32
Default
  #3
vut
Member
 
Join Date: Feb 2014
Posts: 56
Rep Power: 3
vut is on a distinguished road
Hi Tarak,

Your response for gfilip's question interested me alot.

May you give me more details of switching to locDynOneEqEddy model after hundreds of iterations?

More generally, I am searching how to initialize a LES simulation from a known solution?

Thank in advance,

VUT
vut is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences in solution method for pisoFoam and buoyantBoussinesqPisoFoam mchurchf OpenFOAM 6 September 10, 2013 23:24
pisoFoam compiling error with OF 1.7.1 on MAC OSX Greg Givogue OpenFOAM Programming & Development 3 March 4, 2011 18:18
Trouble migrating oodles to pisoFoam while changing from OF 1.5 to 1.7 sebi OpenFOAM 0 December 7, 2010 10:00
Grid Check Fails in Parallel Processing Mode askance Main CFD Forum 0 October 20, 2010 10:11
the result of pitzDaily using simpleFoam and pisoFoam Kr_kim OpenFOAM Running, Solving & CFD 1 March 16, 2010 14:38


All times are GMT -4. The time now is 15:36.