CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

swak4Foam compilation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 9, 2011, 21:31
Default swak4Foam compilation problem
  #1
Member
 
Ganesh Vijayakumar
Join Date: Jan 2010
Posts: 43
Rep Power: 7
ganeshv is on a distinguished road
I have a problem with compiling swak4Foam using intel compilers. I have OpenFOAM 1.6-ext compiled and running just fine. However swak4Foam doesn't compile. (I should mention that it compiles and works just fine using gcc compilers on my laptop.... and it's very very useful ..but a lot of people already know that!)

Shown below is the first error

SOURCE=GlobalVariablesRepository.C ; icpc -DIntel -Dlinux64 -DWM_DP -wd327,584,654,819,1125,1476,1505,1572 -ansi-alias -O3 -fno-alias -fargument-noalias-global -unroll0 -DNoRepository -IMake/linux64IccDPOpt -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/sampling/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/triSurface/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/lagrangian/basic/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -IlnInclude -I. -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64IccDPOpt/GlobalVariablesRepository.o
/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude/pTraits.H(52): error: not a class or struct name
public PrimitiveType
^
detected during instantiation of class "Foam:Traits<PrimitiveType> [with PrimitiveType=char [48]]" at line 64 of "GlobalVariablesRepository.C"

/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude/pTraits.H(52): error: not a class or struct name
public PrimitiveType
^
detected during instantiation of class "Foam:Traits<PrimitiveType> [with PrimitiveType=Foam::Ostream &(Foam::Ostream &)]" at line 64 of "GlobalVariablesRepository.C"
ganeshv is offline   Reply With Quote

Old   November 9, 2011, 21:36
Default bison
  #2
Member
 
Ganesh Vijayakumar
Join Date: Jan 2010
Posts: 43
Rep Power: 7
ganeshv is on a distinguished road
I should mention that I originally had bison 2.3 installed at first. But I later installed m4 1.16 and bison 2.5 and it make no difference.
ganeshv is offline   Reply With Quote

Old   November 10, 2011, 05:35
Default
  #3
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by ganeshv View Post
I should mention that I originally had bison 2.3 installed at first. But I later installed m4 1.16 and bison 2.5 and it make no difference.
The parts you mention in your original posting are not affected by the bison-version.

Actually, the problem was discussed this week (swak4Foam installation on 2.0) and it seems that the problem is the Intel compiler. Fix is also found in that thread.

BTW: has anyone benched the Intel-compiler against a recent version of gcc (preferably on the same machine)? Just wondering whether there is a speed improvement that makes it worth the trouble it causes
gschaider is offline   Reply With Quote

Old   November 10, 2011, 10:37
Default
  #4
Member
 
Ganesh Vijayakumar
Join Date: Jan 2010
Posts: 43
Rep Power: 7
ganeshv is on a distinguished road
I tried that fix.

export WM_COMPILER=Gcc; cd Utilities; wclean all; wmake all
This is what I get. Where are the .hh files? I get a few more errors of the same kind.

Making dependency list for source file funkySetFields.C
could not open file FieldValueExpressionParser.tab.hh for source file funkySetFields.C
SOURCE=funkySetFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -IMake/linux64IccDPOpt -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64IccDPOpt/funkySetFields.o
In file included from funkySetFields.C:41:
../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:18:45: error: FieldValueExpressionParser.tab.hh: No such file or directory
ganeshv is offline   Reply With Quote

Old   November 10, 2011, 20:31
Default
  #5
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by ganeshv View Post
I tried that fix.

export WM_COMPILER=Gcc; cd Utilities; wclean all; wmake all
This is what I get. Where are the .hh files? I get a few more errors of the same kind.

Making dependency list for source file funkySetFields.C
could not open file FieldValueExpressionParser.tab.hh for source file funkySetFields.C
SOURCE=funkySetFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -IMake/linux64IccDPOpt -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/brashear/guv106/OpenFOAM/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64IccDPOpt/funkySetFields.o
In file included from funkySetFields.C:41:
../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:18:45: error: FieldValueExpressionParser.tab.hh: No such file or directory
Hm. Compilation of Library before that was successful? If yes: you didn't wclean anywhere in Library (possibly during an attempt to fix things)? Because that might have remove the lnInclude-directory (and the .hh-file/link with it)
gschaider is offline   Reply With Quote

Old   November 11, 2011, 17:39
Default
  #6
Member
 
Ganesh Vijayakumar
Join Date: Jan 2010
Posts: 43
Rep Power: 7
ganeshv is on a distinguished road
I couldn't get swak4Foam to compile with icc/11.1. I switched to icc/12.0 and then it worked until funkySet* libraries had to be compiled. I then adopted the work around posted in that thread and described above. It works. My simulation that uses swak4Foam with cellZone averages also works. Thanks for helping Bernard Gschaider.
ganeshv is offline   Reply With Quote

Reply

Tags
compilation, intel, swak4foam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF compilation problem on Linux System Nitin Pathak FLUENT 1 July 10, 2014 11:41
Handling cyclic BC from gambit to openfoam for a cascade airfoil problem - OF 1.6 maverick OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 2 June 18, 2011 04:36
Velocity profiles problem behind the elbow (3D problem) kabat73 FLUENT 8 May 9, 2010 04:26
natural convection problem for a CHT problem Se-Hee CFX 2 June 10, 2007 06:29
Adiabatic and Rotating wall (Convection problem) ParodDav CFX 5 April 29, 2007 19:13


All times are GMT -4. The time now is 09:14.