CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Problem Setting floatTransfer Parameter

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 16, 2011, 10:52
Default Problem Setting floatTransfer Parameter
  #1
New Member
 
Geoffrey Bell
Join Date: Feb 2011
Posts: 1
Rep Power: 0
GeoffreyJBell is on a distinguished road
Hi,


I have a case in porousSimpleFoam that converges easily when run on a single processor as a serial job. However, when run in parallel using the follwing commands fails to converge:



runApplication blockMesh
runApplication setSet -batch createCanopy.setSet
runApplication setsToZones

runApplication decomposePar
runParallel redistributeMeshPar 4 -overwrite
runParallel renumberMesh 4 -overwrite

runParallel porousSimpleFoam 4

runApplication reconstructParMesh -constant
runApplication reconstructPar




Since my understanding is that failure to converge can result from only single-precision communication between the processors, and that this transfer is controlled using the floatTransfer parameter, and possibly nProcsSimpleSum parameters in controlDict, I have made the following entries in controlDict:

floatTransfer 1;
nProcsSimpleSum 4;

Despite this however, the following is what appears at the top of the log file for porousSimpleFoam.

Note that floatTransfer is still 0, and nProcsSimpleSum is also still 0:

nProcs : 4
Slaves :
3
(
Pavilion.32246
Pavilion.32247
Pavilion.32248
)

Pstream initialized with:
floatTransfer : 0
nProcsSimpleSum : 0
commsType : nonBlocking
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations


I would like to be able to change these parameters for trouble-shooting purposes, and I am not sure what I am doing wrong here when trying to change them. I was wondering if anyone might know how I could do this?

Thanks,


Geoff Bell
GeoffreyJBell is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem setting C_MU_T with DEFINE_ADJUST Andy FLUENT 2 July 30, 2014 05:05
Help setting up combustor problem Tom FLUENT 0 February 5, 2005 02:20
Periodic flow boundary condition problem sudha FLUENT 3 April 28, 2004 08:40
Small problem with VR editor Song Phoenics 1 April 22, 2003 17:34
CF4 - need advice on setting up multiphase problem Brett Towler CFX 2 August 18, 2000 16:38


All times are GMT -4. The time now is 14:52.