CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

RASmodel not detected

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By romant

Reply
 
LinkBack Thread Tools Display Modes
Old   January 10, 2012, 09:10
Default RASmodel not detected
  #1
Ofc
New Member
 
Join Date: Nov 2011
Posts: 9
Rep Power: 5
Ofc is on a distinguished road
Hello Foamers,

I am using the twoPhaseEulerFoam solver. I try to set the RASmodel in the RASproperties. But whatever I write there (e.g. kEpsilon, LaunderSharmaKE or whatModelDoIUse, ...) the solver will always run.
Also I can switch off the turbulence in the file and the solver is still needing a k and epsilon file in the /0 folder. I tried to run the case on different pc's and the error repeats so guess it must be one of my case settings.
I want to change my model to k-omega-SST, but when I do the solver still needs k and epsilon and does not need omega in the /0 file. Any suggestions what might be wrong or how to solve the issue?

Thanks for your help,
Ofc is offline   Reply With Quote

Old   January 11, 2012, 06:11
Default
  #2
Senior Member
 
romant's Avatar
 
Roman Thiele
Join Date: Aug 2009
Location: Stockholm, Sweden
Posts: 359
Rep Power: 12
romant is on a distinguished road
Hej,

I just checked the files for twoPhaseEulerFoam (something you might wanna do), but it seems that the only model you can use is kEpsilon. There is a special kEpsilon version which calculates the nuEff based on both phases. This is the reason you can't switch. In order to switch, you will have to implement this into the solver by hand.
Ofc likes this.
__________________
~roman
romant is offline   Reply With Quote

Old   January 12, 2012, 10:19
Default
  #3
Ofc
New Member
 
Join Date: Nov 2011
Posts: 9
Rep Power: 5
Ofc is on a distinguished road
Thank you,

that explains all. It's a good idea to investigate the solver. I put it on top of my ToDo-list.
Ofc is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Divergence detected in AMG solver: ads-0 Patrino FLUENT 4 April 18, 2014 01:53
Quarter Burner mesh with periosic condition SamCanuck FLUENT 2 August 31, 2011 11:34
Error detected by routine 201 CFX 1 April 19, 2010 16:17
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31
user defined function cfduser CFX 0 April 29, 2006 10:58


All times are GMT -4. The time now is 20:03.