CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   decomposePar failed in "field transfer" (http://www.cfd-online.com/Forums/openfoam-solving/97224-decomposepar-failed-field-transfer.html)

aqua February 12, 2012 15:28

decomposePar failed in "field transfer"
 
Dear all,
I am trying to run a case in parallel, when run "decomposePar", it worked fine before "field transfer". no error, on warning, but just stopped..as follows:

Processor 15
Number of cells = 30270
Number of faces shared with processor 12 = 420
Number of faces shared with processor 14 = 1096
Number of faces shared with processor 8 = 343
Number of faces shared with processor 10 = 551
Number of processor patches = 4
Number of processor faces = 2410
Number of boundary faces = 8475

Number of processor faces = 10809
Max number of processor patches = 7
Max number of faces between processors = 2410

Processor 0: field transfer
Initializing the GGI interpolator between master/shadow patches: iminy/imaxy
Initializing the GGI interpolator between master/shadow patches: ominy/omaxy

it just stopped here, without finishing the decomposePar. The result is, in processor0/1/2/3/4/5... there is only the file "constant", but no file "0"..


Does anyone may help on this? what may be the problem?

Thank you so much!!

Aqua

Abhishekd18 February 12, 2012 23:53

Hi,

That means you don't have the initial conditions folder named "0". If you are using different time for initial condition, try changing the start time in controlDict.

aqua February 14, 2012 07:00

Hello, Abhishek,

Thank you so much for your reply. Turned out that the mesh is not right. So current I am trying to modify the mesh...

Cheers!

Aqua


All times are GMT -4. The time now is 23:42.