CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   symmetryPlane in moving mesh? (http://www.cfd-online.com/Forums/openfoam-solving/98689-symmetryplane-moving-mesh.html)

wavemaster March 16, 2012 07:45

symmetryPlane in moving mesh?
 
1 Attachment(s)
Dear All,
I am running some moving meshes successfully as long as I model the whole domain. If I run something rotating around an axis I would of course like to use the symmetry plane normal to the axis to save some time and computational power.
However after some time i get deformation out of the plane and my simulation blows up.
2d cases also work fine.
I have seen this behavior in OpenFOAM 1.6,1.7 and 2.* so don't think it is version dependent.
Is symmetryPlane supposed to work? Shall I report a bug? Could this be due to some mesh motion tolerance settings or what did i miss?
Thanks for any comments,
Happy St. Patricks Day,
Pal

fcuevas March 19, 2012 10:48

Hi, I had problems too using the symmetryPlane BC, it is posted here
http://www.cfd-online.com/Forums/ope...condition.html
My case is related to heat transport and the problem is when I simulate all the geometry I get different results as when I use the symmetryPlane BC.
Nobody answer me and maybe it could be a bug.

I hope somebody else could tell his/her experience using this BC and if actually is working properly.

wavemaster March 20, 2012 12:34

Hi Felipe,
I never had problems with symmetryPlane condition except for the moving mesh, that is why I am surprised. So any "simple" flow problem seems to work, have never done heat transfer though...
Will have a look at the code when I have some time in the future, strange noone else comments on this...
Cheers,
Pal


All times are GMT -4. The time now is 02:17.