CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

potentialFreeSurfaceFoam parallel run failed?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 15, 2012, 10:38
Default potentialFreeSurfaceFoam parallel run failed?
  #1
New Member
 
Join Date: May 2012
Posts: 1
Rep Power: 0
ahyangyi is on a distinguished road
Hi, everyone. I was just trying out the ocsillatingBox case in the tutorial directory of OpenFOAM 2.1.0. It ran well, but when I changed it to run in parallel, reconstructPar reported segment fault.

This happens every time I try to run it in parallel, no matter how I decompose the mesh nor how many processors I use.

For your information, the reconstructPar fails when it tries to combine the scalar field p_gh.

Anyone also met this problem? Do you have a solution or any suggestion for this?

Thank you very much in advance!
ahyangyi is offline   Reply With Quote

Old   May 15, 2012, 15:44
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings ahyangyi and welcome to the forum!

Well, OpenFOAM 2.1.0 had several bugs and many of them are already fixed in 2.1.x.
If you share the modifications you made to the tutorial case, we (those who go around the forum helping people) can test in 2.1.x and/or check what might be necessary for things to work properly.

Beyond upgrading to 2.1.x, you can also check this thread: Parallel Computing decomposePar

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
First Parallel Run - need some help Gian Maria OpenFOAM 3 June 17, 2011 12:08
ParaView/Parafoam error when making animation Disco_Caine OpenFOAM Paraview & paraFoam 6 September 28, 2010 09:54
Unable to run OF in parallel on a multiple-node cluster quartzian OpenFOAM 3 November 24, 2009 14:37
serial run fine, but parallel run diverged phsieh2005 OpenFOAM Running, Solving & CFD 2 October 6, 2009 08:33
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 04:38.