CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

error to check simulation result: could not find valid OpenFOAM mesh

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 14, 2012, 10:16
Default error to check simulation result: could not find valid OpenFOAM mesh
  #1
New Member
 
YuanLiu
Join Date: Aug 2010
Posts: 10
Rep Power: 5
xiaoyoyo is on a distinguished road
Hi everyone,

I am doing some simulation using chtMultiRegionFoam. I created a mesh with three regions using ICEM, and then run a simple case. everything is good.
Then I tried another case, in which everything is the same except that I used groovyBC to set up the temperature profile of main air inlet. Then simulation is running without any problem. While when I tried to check the result using paraFoam, the paraview didn't work and I got this error message:

Quote:
ERROR: In /home/opencfd/OpenFOAM/OpenFOAM-2.1.0/applications/utilities/postProcessing/graphics/PV3Readers/PV3FoamReader/PV3FoamReader/vtkPV3FoamReader.cxx, line 215
vtkPV3FoamReader (0x33b7ab0): could not find valid OpenFOAM mesh


ERROR: In /home/opencfd/OpenFOAM/ThirdParty-dev/ParaView-3.12.0/VTK/Filtering/vtkExecutive.cxx, line 756
vtkPVCompositeDataPipeline (0x33d3310): Algorithm vtkPV3FoamReader(0x33b7ab0) returned failure for request: vtkInformation (0x33c4a70)
Debug: Off
Modified Time: 74306
Reference Count: 1
Registered Events: (none)
Request: REQUEST_INFORMATION
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0

Segmentation fault
I noticed that in the error message, the path of the openFoam is /home/opencfd/OpenFOAM
while I believe that the openFOam and paraView are both installed in root/opt folder
Is this the possible reason?

Anyone can help?
thanks a lot!
xiaoyoyo is offline   Reply With Quote

Old   June 14, 2012, 10:23
Default
  #2
Member
 
supercommandodhruv
Join Date: Sep 2011
Posts: 57
Rep Power: 4
dhruv is on a distinguished road
Hi,

Have you created the three separate files for paraview post-processing, for the three different regions?

Dhruv.

Quote:
Originally Posted by xiaoyoyo View Post
Hi everyone,

I am doing some simulation using chtMultiRegionFoam. I created a mesh with three regions using ICEM, and then run a simple case. everything is good.
Then I tried another case, in which everything is the same except that I used groovyBC to set up the temperature profile of main air inlet. Then simulation is running without any problem. While when I tried to check the result using paraFoam, I got this error message:



Anyone can help?
thanks a lot!
dhruv is offline   Reply With Quote

Old   June 14, 2012, 10:27
Default
  #3
New Member
 
YuanLiu
Join Date: Aug 2010
Posts: 10
Rep Power: 5
xiaoyoyo is on a distinguished road
Quote:
Originally Posted by dhruv View Post
Hi,

Have you created the three separate files for paraview post-processing, for the three different regions?

Dhruv.
yes, I did it
Actually, I checked the former simulation (the one I didn't using groovyBC), even though I got the same error message, I still can open the result. It is so strange!
xiaoyoyo is offline   Reply With Quote

Old   June 14, 2012, 14:37
Default
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,755
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by xiaoyoyo View Post
yes, I did it
Actually, I checked the former simulation (the one I didn't using groovyBC), even though I got the same error message, I still can open the result. It is so strange!
It is really strange, especially as paraFoam compares about not finding a mesh. And reading the mesh has to come before reading the fields and only when the fields are read will groovyBC kick in.

Some questions:

a) is hat you wrote in the original posting ALL the output?

b) are you REALLY sure that the case is the same apart from groovyBC? Try the following: comment out groovyBC and put in "type zeroGradient". Also comment out the libs-entry in controlDict. See if paraview still fails

c) have you tried the builtin OpenFOAM-reader in paraview? Just create one stub-file foo.foam in the case and when opening that it should recognize all the regions
gschaider is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Generating Mesh for STL Car in Windtunnel Simulation tommymoose ANSYS Meshing & Geometry 48 April 15, 2013 04:24
Mesh Check fails in OpenFoam ???? Gitesh P OpenFOAM 3 June 30, 2011 05:48
snappyHexMesh won't work - zeros everywhere! sc298 OpenFOAM Native Meshers: snappyHexMesh and Others 2 March 27, 2011 21:11
Problems in compiling paraview in Suse 10.3 platform chiven OpenFOAM Installation 3 December 1, 2009 07:21
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 20:30


All times are GMT -4. The time now is 21:28.