CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

PyFoam installation question

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 18, 2012, 16:59
Default PyFoam installation question
  #1
New Member
 
Caroline Vandame
Join Date: Aug 2010
Posts: 26
Rep Power: 7
CaroVandame is on a distinguished road
Hi Foamers!

I have a little question regarding the installation of PyFoam on Ubuntu 11.10
I tried following the steps from the wiki:
- I downloaded the latest tar and did the untar in my home folder
- I went into the directory PyFoam-0.5.7
- I installed it with the command: python setup.py install.

It did not show any error message. However, when checking the installation, the command "print PyFoam.FoamInformation.foamTutorials()", it returns
/opt/openfoam211/tutorials

My knowledge in package installations is quite limited. One thing I know is that 3 versions of Python are installed in my Ubuntu distribution: 2.6, 2.7 and 3 and PyFoam doesn't work with Python3. However, "python -V" returns Python 2.7.2+, so it seems ok.

Any advice for a (almost complete) beginner?

Thanks so much
Caroline.
CaroVandame is offline   Reply With Quote

Old   June 18, 2012, 19:44
Default
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,920
Rep Power: 41
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by CaroVandame View Post
Hi Foamers!

I have a little question regarding the installation of PyFoam on Ubuntu 11.10
I tried following the steps from the wiki:
- I downloaded the latest tar and did the untar in my home folder
- I went into the directory PyFoam-0.5.7
- I installed it with the command: python setup.py install.

It did not show any error message. However, when checking the installation, the command "print PyFoam.FoamInformation.foamTutorials()", it returns
/opt/openfoam211/tutorials

My knowledge in package installations is quite limited. One thing I know is that 3 versions of Python are installed in my Ubuntu distribution: 2.6, 2.7 and 3 and PyFoam doesn't work with Python3. However, "python -V" returns Python 2.7.2+, so it seems ok.

Any advice for a (almost complete) beginner?

Thanks so much
Caroline.
Not quite sure what your problem is. The test you stated above should return the value of $FOAM_TUTORIALS and the value seems alright.

Have you tried pyFoamVersion.py (the utility)?
gschaider is offline   Reply With Quote

Old   June 19, 2012, 11:02
Default
  #3
New Member
 
Caroline Vandame
Join Date: Aug 2010
Posts: 26
Rep Power: 7
CaroVandame is on a distinguished road
Sorry I just realized my post wasn't complete.
I'm not sure what happened, but it seems my computer didn't recognize any pyFoam utilities. I ran "python setup.py install" again, and now it works.
maybe there was an error message the first time around that I didn't see.

Thanks for being there and quick to help though!
Caroline
CaroVandame is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
pyFoam and paraview eelcovv OpenFOAM Paraview & paraFoam 28 May 30, 2016 09:23
OpenFoam 2.0.0 installation Jan_Peters OpenFOAM Installation 86 April 27, 2012 05:32
Source Pack Installation OpenFOAM Version 2.1.0 on Redhat Linux Indrajit OpenFOAM Installation 1 April 1, 2012 04:39
Difficulties using parafoam, one critical error in installation of OpenFOAM-1.6 PeterNaa OpenFOAM Installation 4 April 9, 2010 08:48
Installing OpenFOAM-1.6.x on OpenSUSE 11.2, A question to the developers Ahmed OpenFOAM Installation 0 December 5, 2009 06:03


All times are GMT -4. The time now is 15:26.