CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Simulation running in background

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 21, 2012, 05:02
Default Simulation running in background
  #1
Senior Member
 
Samuele Z
Join Date: Oct 2009
Location: Mozzate - Co - Italy
Posts: 490
Rep Power: 9
samiam1000 is on a distinguished road
Dear All,

I am running a simulation in background (using foamJob). It started well and after some hours, I had a problem: the simulation seems to run properly, but nothing is written.

In fact, if I give the `top' command, I get this:
Code:
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
11571 rduser    20   0  383m  94m 4368 R  100  2.4   2434:38 buoyantPimpleFo    
 9040 rduser    20   0  421m 132m 4392 R  100  3.3   8210:47 buoyantPimpleFo    
 9041 rduser    20   0  425m 135m 4384 R  100  3.4   8211:35 buoyantPimpleFo    
11570 rduser    20   0  374m  86m 4380 R  100  2.2   2434:24 buoyantPimpleFo    
   44 root      20   0     0    0    0 S    0  0.0   5:23.32 kworker/3:1        
  741 root      20   0 63972 1320 1076 S    0  0.0  23:54.09 nmbd               
 9039 rduser    20   0 3833m 1.3g  652 S    0 32.6   2:23.47 mpirun             
    1 root      20   0 24172 1448  728 S    0  0.0   0:08.86 init               
    2 root      20   0     0    0    0 S    0  0.0   0:01.50 kthreadd           
    3 root      20   0     0    0    0 S    0  0.0   0:50.53 ksoftirqd/0        
    6 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0
Also, trying to give the `ps -ef | grep rduser' command, I get the following output:
Code:
rduser@slnxepmi05:/OPENFOAM/cases/moving_door_def_flow/test/opening/we3Ter$ ps -ef | grep rduser
rduser    9039     1  0 Nov15 ?        00:02:23 /usr/bin/mpirun -np 2 -hostfile machines /opt/openfoam210/bin/foamExec -prefix /opt buoyantPimpleFoam -parallel
rduser    9040  9039 99 Nov15 ?        5-16:50:10 buoyantPimpleFoam -parallel
rduser    9041  9039 99 Nov15 ?        5-16:50:58 buoyantPimpleFoam -parallel
rduser   11569     1  0 Nov19 ?        00:01:51 /usr/bin/mpirun -np 2 -hostfile machines /opt/openfoam210/bin/foamExec -prefix /opt buoyantPimpleFoam -parallel
rduser   11570 11569 99 Nov19 ?        1-16:33:47 buoyantPimpleFoam -parallel
rduser   11571 11569 99 Nov19 ?        1-16:34:01 buoyantPimpleFoam -parallel
rduser   13385   657  0 08:57 ?        00:00:00 smbd -F
root     13386   728  0 08:59 ?        00:00:00 sshd: rduser [priv] 
rduser   13409 13386  0 08:59 ?        00:00:00 sshd: rduser@pts/0  
rduser   13410 13409  0 08:59 pts/0    00:00:00 -bash
rduser   13772 13410  0 10:13 pts/0    00:00:00 ps -ef
rduser   13773 13410  0 10:13 pts/0    00:00:00 grep --color=auto rduser
rduser@slnxepmi05:/OPENFOAM/cases/moving_door_def_flow/test/opening/we3Ter$
The problem is that nothing is written after a certain time step and this happens for 2 different simulation (the 2 that are running as you can see in the commands above).

Any idea? What could I do?

Thanks a lot,

Samuele
samiam1000 is offline   Reply With Quote

Old   November 22, 2012, 05:24
Default
  #2
Member
 
Join Date: Nov 2010
Location: Tokyo / Japan
Posts: 40
Rep Power: 6
Hanzo is on a distinguished road
how are your output setting in system/controlDict defined?
Hanzo is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rigid body motion error when restarting a terminated FSI simulation lingdeer ANSYS 1 May 19, 2013 01:40
Running Fluent in the Background Sidewinder FLUENT 5 March 30, 2010 14:28
Steps to be completed before running the simulation Saha_AIT STAR-CCM+ 3 December 1, 2009 11:54
Replacing mesh while running a simulation akultane CFX 1 November 15, 2009 14:46
What do you CFD guys do during a long simulation running? bearcat Main CFD Forum 5 July 23, 2009 08:08


All times are GMT -4. The time now is 18:32.