CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Gettings started after installing OpenFOAM 2.1.1 in Ubuntu 12.10 (http://www.cfd-online.com/Forums/openfoam/109625-gettings-started-after-installing-openfoam-2-1-1-ubuntu-12-10-a.html)

yoddha24 November 21, 2012 10:02

Gettings started after installing OpenFOAM 2.1.1 in Ubuntu 12.10
 
i installed OpenFOAM on ubuntu 12.10 sucessfully as per guidelines given at:

But when i try to run it it shows this error message repeatedly! I am new to OpenFOAM so i would require guidance:

when i wrote "icoFoam" at command prompt, following message was displayed:
---------------------------------------------------------------------------------------------------------------------
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.1.1-221db2718bbb
Exec : icoFoam
Date : Nov 21 2012
Time : 19:29:33
Host : "sandeep-desktop"
PID : 2908
Case : /home/sandeep/OpenFOAM/OpenFOAM-2.1.1/tutorials/incompressible/icoFoam/cavity
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0



--> FOAM FATAL ERROR:
Cannot find file "points" in directory "polyMesh" in times 0 down to constant

From function Time::findInstance(const fileName&, const word&, const IOobject::readOption, const word&)
in file db/Time/findInstance.C at line 188.

FOAM exiting
------------------------------------------------------------------------------------

khashi November 21, 2012 13:42

Dear yoddha24
by the type of the error that you got, it shows you have some problem with your mesh. better to check the folder constant/PolyMesh in your case.
I think you might have converted the mesh or copied it from somewhere else. so you should check that procedure too.
if you provide more details about the mesh, may be we could help you more.

yoddha24 November 21, 2012 22:26

Quote:

Originally Posted by khashi (Post 393495)
Dear yoddha24
by the type of the error that you got, it shows you have some problem with your mesh. better to check the folder constant/PolyMesh in your case.
I think you might have converted the mesh or copied it from somewhere else. so you should check that procedure too.
if you provide more details about the mesh, may be we could help you more.

Dear khashi,

Since I downloaded using wget as proposed in the instructions so that source must be corrupted. I did not altered any file. Could you please let me know a known good source for files.

Regards

neosoyo November 22, 2012 04:45

i have the same error. the problem is the blockMesh.

--> FOAM FATAL ERROR:
Failed writing polyMesh.

From function blockMesh
in file blockMeshApp.C at line 336.

FOAM exitin

seems to be some previlegies problem...any clue?

wyldckat November 22, 2012 04:53

Greetings to all!

I've moved your posts to a new thread, specifically for these kinds of questions on how to get started! ;)

From your questions, it looks like you guys didn't read very well the User Guide ;)
It all begins here: http://www.openfoam.org/docs/user/tu...s.php#x4-30002 - namely with these commands:
Quote:

Code:

mkdir -p $FOAM_RUN
cp -r $FOAM_TUTORIALS $FOAM_RUN


Then continue reading, starting with the first tutorial: http://www.openfoam.org/docs/user/cavity.php

Have fun!
Bruno

khashi November 22, 2012 11:34

Dear yoddha24
please follow Bruno's last post descriptions. it will help you to overcome the problem, in any case that you encounter more difficulties, don't hesitate to contact me.

khashi

yoddha24 November 22, 2012 11:40

Thanx
 
Quote:

Originally Posted by khashi (Post 393675)
Dear yoddha24
please follow Bruno's last post descriptions. it will help you to overcome the problem, in any case that you encounter more difficulties, don't hesitate to contact me.

khashi

Dear Khasi,

Thanx for info. I managed to know what was wrong by Bruno's post.

regards

neosoyo November 22, 2012 12:46

Quote:

Originally Posted by wyldckat (Post 393606)
Greetings to all!

I've moved your posts to a new thread, specifically for these kinds of questions on how to get started! ;)

From your questions, it looks like you guys didn't read very well the User Guide ;)
It all begins here: http://www.openfoam.org/docs/user/tu...s.php#x4-30002 - namely with these commands:
Then continue reading, starting with the first tutorial: http://www.openfoam.org/docs/user/cavity.php

Have fun!
Bruno

i've found it!! i created and copied a folder tree for root user too! :D:o

don't realize that..check this too yoddha24.

working fine now, thanks!


All times are GMT -4. The time now is 00:20.