CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Missing Output of debugwitch (http://www.cfd-online.com/Forums/openfoam/114578-missing-output-debugwitch.html)

kflora March 13, 2013 12:33

Missing Output of debugSwitch
 
Hi All,

I am not able to see the output of the debugSwitch for the nutWallFunction after it is appended to my controlDict file for the damBreak tutorial on OpenFoam 2.2.0 using a desktop as:

application interFoam;
startFrom latestTime;
startTime 0;
stopAt endTime;
endTime 1;
deltaT 0.001;
writeControl adjustableRunTime;
writeInterval 0.05;
purgeWrite 0;
writeFormat ascii;
writePrecision 6;
writeCompression uncompressed;
timeFormat general;
timePrecision 6;
runTimeModifiable yes;
adjustTimeStep on;
maxCo 0.2;
maxAlphaCo 0.2;
maxDeltaT 1;

DebugSwitches
{
nutWallFunction 1;
}


The nut file in the 0 directory uses the wall function on the wall such as:

lowerWall
{
type nutkWallFunction;
value uniform 0;
}


so I assume there should be some debug info but while the output shows the user supplied change to the debugSwitch, I don't see any output for the nutWallFunction.

Create time

Overriding DebugSwitches according to controlDict
nutWallFunction 1;


Create mesh for time = 0


PIMPLE: Operating solver in PISO mode

Reading field p_rgh

Reading field U

Reading/calculating face flux field phi

Reading transportProperties

Selecting incompressible transport model Newtonian
Selecting incompressible transport model Newtonian
Selecting turbulence model type RASModel
Selecting RAS turbulence model kEpsilon
kEpsilonCoeffs
{
Cmu 0.09;
C1 1.44;
C2 1.92;
sigmaEps 1.3;
}


Reading g
Calculating field g.h

No finite volume options present

time step continuity errors : sum local = 0, global = 0, cumulative = 0
DICPCG: Solving for pcorr, Initial residual = 0, Final residual = 0, No Iterations 0
time step continuity errors : sum local = 0, global = 0, cumulative = 0
Courant Number mean: 0 max: 0

Starting time loop

Courant Number mean: 0 max: 0
Interface Courant Number mean: 0 max: 0
deltaT = 0.00119048
Time = 0.00119048

MULES: Solving for alpha1
Phase-1 volume fraction = 0.130194 Min(alpha1) = 0 Max(alpha1) = 1
MULES: Solving for alpha1
Phase-1 volume fraction = 0.130194 Min(alpha1) = 0 Max(alpha1) = 1
MULES: Solving for alpha1
Phase-1 volume fraction = 0.130194 Min(alpha1) = 0 Max(alpha1) = 1
MULES: Solving for alpha1
Phase-1 volume fraction = 0.130194 Min(alpha1) = 0 Max(alpha1) = 1
DICPCG: Solving for p_rgh, Initial residual = 1, Final residual = 0.0421443, No Iterations 3
time step continuity errors : sum local = 0.000350496, global = -5.70682e-10, cumulative = -5.70682e-10
DICPCG: Solving for p_rgh, Initial residual = 0.00452632, Final residual = 0.000197661, No Iterations 12
time step continuity errors : sum local = 1.63325e-05, global = -6.25211e-06, cumulative = -6.25268e-06
DICPCG: Solving for p_rgh, Initial residual = 0.000284331, Final residual = 6.57447e-08, No Iterations 52
time step continuity errors : sum local = 1.13306e-08, global = 1.33958e-09, cumulative = -6.25134e-06
DILUPBiCG: Solving for epsilon, Initial residual = 0.0206374, Final residual = 5.504e-09, No Iterations 3
DILUPBiCG: Solving for k, Initial residual = 1, Final residual = 7.76563e-09, No Iterations 4
ExecutionTime = 0.04 s ClockTime = 0 s

Courant Number mean: 0.0005733 max: 0.00515206
Interface Courant Number mean: 0 max: 0
deltaT = 0.00139456
Time = 0.00258503


What am I missing? Are the results elsewhere? Is this the wrong debugSwitch (I've tried several and don't see any difference in the output log)?

Related to this issue is when I run the same case (OF 2.1.1) on a cluster, not only do I not see any output of the Wall Funciton in the log file, but the statement acknowledging my debug switch "Overriding DebugSwitches according to controlDict
nutWallFunction 1;"

is also absent from the output log. Any ideas on how to solve this (maybe a permissions issue?)?


All times are GMT -4. The time now is 00:27.