CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

swak4Foam install in OF 2.1 error, Please help me

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 24, 2013, 15:14
Default swak4Foam install in OF 2.1 error, Please help me
  #1
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Good Day Folks,
I try to install swak4Foam in Openfoam 2.1, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   July 24, 2013, 17:13
Default
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Good Day Folks,
I try to install swak4Foam in Openfoam 2.1, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me
If it is your plan to get more answers by posting the same question every two hours in a different thread (http://www.cfd-online.com/Forums/ope...l#post441746):) won't work. Usually this annoys the people who already answered your question and they will stop answering altogether
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request

Last edited by gschaider; July 24, 2013 at 17:19. Reason: Add closing paranthesis
gschaider is offline   Reply With Quote

Old   July 25, 2013, 00:18
Default
  #3
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Thanks for suggestion gschaider, finally I did, Now it works fine

I understand the problem, but you are telling , you didn't use Ubuntu, that the reason I start new thread, kindly let know any simple trick, to get more help without making annoying our OF folks.I am new to OF.

And also let me know which one are you using for OF.
__________________
Million Thanks,
David

"Small Dream is a Crime"

Last edited by psk; July 25, 2013 at 04:32.
psk is offline   Reply With Quote

Old   July 25, 2013, 05:13
Default
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Thanks for suggestion gschaider, finally I did, Now it works fine

I understand the problem, but you are telling , you didn't use Ubuntu, that the reason I start new thread, kindly let know any simple trick, to get more help without making annoying our OF folks.I am new to OF.

And also let me know which one are you using for OF.
Then you should have updated the question with the new information you've got. Something like "Have Ubuntu. How to install bison?" That way people don't have to start from scratch.

Concerning the installation of bison: http://bit.ly/144S7Pf The second link (http://en.kioskea.net/faq/30635-how-...n-under-ubuntu) looks nice (and there is a number of other links that looks promising)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   July 25, 2013, 11:48
Default
  #5
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Good Day, Thanks for your reply & information gschaider,

I already did that one, kindly see this link (http://www.cfd-online.com/Forums/ope...tml#post441825 )

Also Kindly let me know, how to convert matlab m file to python? I go through this link:[ http://ompclib.appspot.com/m2py ], while running the converted python script it shows lot of error, I am new to python. If you have any idea share me.
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
swak4foam newbie29 OpenFOAM Installation 82 July 18, 2015 17:16
swak4foam fails in parallel with -otherTime? Phicau OpenFOAM Post-Processing 3 June 26, 2013 13:00
unable to install openfoam 1.7 using apt-get maazhmd OpenFOAM Installation 7 July 24, 2011 11:18
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 18:56
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43


All times are GMT -4. The time now is 23:37.