CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   OpenFOAM and linux distros (http://www.cfd-online.com/Forums/openfoam/61026-openfoam-linux-distros.html)

billy September 6, 2005 13:05

I would like to know on which
 
I would like to know on which linux distros you have successfully installed OpenFOAM. Because I was thinking of changing to another linux distribution or upgrade and I would like to know which work.

I will start with my experience:

Version: OpenFOAM-1.1 and OpenFOAM-1.2
Distro: Suse 9.2
Outcome: OK

Version: OpenFOAM-1.2
Distro: Fedora (not sure whic
Outcome: OK

henry September 6, 2005 13:16

The OpenFOAM-1.2 linux binary
 
The OpenFOAM-1.2 linux binary packs were built on a machine running SuSE 9.3 and we have also checked it on SuSE 9.2 and 9.1 but not on any other Linux distributions. At OpenCFD we run SuSE exclusively because we are very happy with it and don't see a need to change.

hsieh September 6, 2005 14:14

I have used: Fedora 3 32-bi
 
I have used:

Fedora 3 32-bit: no problem
Fedora 3 64-bit: Cannot run FoamX, solvers run OK.
Fedora 4 32-bit and 64 bit: Cannot run FoamX, solvers run OK.

santos September 6, 2005 16:30

I have tested both OpenFOAM-1.
 
I have tested both OpenFOAM-1.1 and OpenFOAM-1.2 on Debian and Ubuntu, and it ran wihtout any problem.

matej September 6, 2005 17:50

I have successfully installed
 
I have successfully installed and tested OpenFOAM 1.1 on Fedora 3 64-bit,

and

both OpenFOAM 1.1 and 1.2 on GentooAMD64.

billy September 6, 2005 19:20

Has anyone installed it on Sus
 
Has anyone installed it on Suse 10 (beta version)?

I am thinking of installing suse 10 when the release version is available.

sergei September 7, 2005 03:05

I am running 1.2 on suse 10 (x
 
I am running 1.2 on suse 10 (x86,laptop with pentium 3.2 HT)
Sometimes I have problems with paraview - it takes almost all the resources, but rest seems OK.

adorean September 7, 2005 12:38

I have installed and used Open
 
I have installed and used OpenFOAM 1.1 on Slackware 10.1. It worked just fine.

braennstroem September 8, 2005 01:43

It works well on 'archlinux' a
 
It works well on 'archlinux' and 'scientific linux'.


All times are GMT -4. The time now is 02:12.