CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Critical errors during OpenFoam installation in OpenSuse 11.0

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 22, 2009, 10:51
Default Critical errors during OpenFoam installation in OpenSuse 11.0
  #1
New Member
 
Alexandre M S Costa
Join Date: Apr 2009
Posts: 16
Rep Power: 8
amscosta is on a distinguished road
Dear Group,
I am trying to install OpenFOAM in a OpenSuse 11.1 system pc.
However I am getting the following :
Executing /home/amscosta/OpenFOAM/OpenFOAM-1.5/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: pcu-95588
OS: Linux version 2.6.27.7-9-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/amscosta/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/amscosta/OpenFOAM/amscosta-1.5 yes no
$WM_THIRD_PARTY_DIR /home/amscosta/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/amscosta/OpenFOAM/OpenFOAM-1.5 yes yes yes

$FOAM_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_USER_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes no
$WM_DIR ...amscosta/OpenFOAM/OpenFOAM-1.5/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.5/lib/linux64GccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...OAM/amscosta-1.5/lib/linux64GccDPOpt yes yes no
$MPI_ARCH_PATH ...nmpi-1.2.6/platforms/linux64GccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../configure
4.3.2
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /home/amscosta/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /usr/bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/amscosta/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_pcu-95588 Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.


Any guideline is very welcome.
Thanks,
Alex
amscosta is offline   Reply With Quote

Old   April 27, 2009, 10:40
Default
  #2
Senior Member
 
Henrik Rusche
Join Date: Mar 2009
Location: Braunschweig, Niedersachsen, Germany
Posts: 275
Rep Power: 9
henrik is on a distinguished road
Dear Alex,

I have a same messages, but OpenFOAM runs nicely on my machine for quite a while. So give it a try.

Henrik
henrik is offline   Reply With Quote

Old   April 30, 2009, 17:08
Default Reply
  #3
New Member
 
Alexandre M S Costa
Join Date: Apr 2009
Posts: 16
Rep Power: 8
amscosta is on a distinguished road
Hi,
Thanks for the encouragement.
I started the following :
  • cd $HOME/OpenFOAM/$USER-$WM_PROJECT_VERSION/run/tutorials/icoFoam/cavity
  • blockMesh
  • icoFoam
  • paraFoam
However I get a message from the first : blockMesh command not found.
Where they are located ?
Thanks,
Alex
amscosta is offline   Reply With Quote

Old   April 30, 2009, 18:00
Default
  #4
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 208
Rep Power: 9
louisgag is on a distinguished road
Send a message via ICQ to louisgag
Hi Alex,

/home/.../OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linux64GccDPOpt/blockMesh


-Louis
louisgag is offline   Reply With Quote

Old   May 1, 2009, 09:28
Default Folder empty
  #5
New Member
 
Alexandre M S Costa
Join Date: Apr 2009
Posts: 16
Rep Power: 8
amscosta is on a distinguished road
Thanks again,
the directory is empty : amscosta@linux-m6bp:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt> ls
amscosta@linux-m6bp:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt>

If I start following another approach what should be the best linux version to
start with OpenFOAM, i.e., with less incompatibility problems ?

Alex
amscosta is offline   Reply With Quote

Old   May 1, 2009, 14:06
Default
  #6
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 208
Rep Power: 9
louisgag is on a distinguished road
Send a message via ICQ to louisgag
if the directory is empty it might be due to improperly decompressed files (tar -xvvf filename) or to having the improper version (ie 32 instead of 64 bits)

as for the best version of linux I am clueless as the only one i personally used is ubuntu...

good luck,

-Louis
louisgag is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to write k and epsilon before the abnormal end xiuying OpenFOAM Running, Solving & CFD 8 August 27, 2013 15:33
Critical errors gcc and icoFoam during installation of 15 quartzian OpenFOAM Installation 3 December 12, 2008 13:42
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58
Could anybody help me see this error and give help liugx212 OpenFOAM Running, Solving & CFD 3 January 4, 2006 19:07


All times are GMT -4. The time now is 03:52.