CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   paraview doesn't run after upgrading to jaunty (http://www.cfd-online.com/Forums/openfoam/63985-paraview-doesnt-run-after-upgrading-jaunty.html)

lions85 April 26, 2009 09:24

paraview doesn't run after upgrading to jaunty
 
Hello,
I upgraded my ubuntu from 8.10 to 9.04. Before the upgrade my open foam was working very well, and paraview/parafoam too. My paraview was installed by a repository and so it was already compiled to run parafoam. Now, after the upgrade my paraview does not start and i can't find the way to solve it.
The errore message is:

paraview: symbol lookup error: /usr/lib/libmpi_cxx.so.0: undefined symbol: ompi_registered_datareps

I understand that probably the problem is with the package openmpi or something similar, but i really don't know how to fix it.

Maybe i need to come back to ubuntu 8.10 formatting my computer, but i'll do it only as the last way.

COuld anyone help me?
Thank you very much
EManuele Leoni

stomakos April 27, 2009 09:33

I have exactly the same problem... :(

stomakos April 27, 2009 10:34

I found solution...

You have to download all packages that synaptick manager suggests as recommendation and as suggestion as well...
You will find this option if you write 'paraview' in synaptick manager and do right click on paraview...

Good luck!

lions85 April 27, 2009 17:39

Yes, now I manage to open paraview!!! The problem is that now my paraview doesn't work with the command parafoam, asking to select the way to open the file. This the same problem that I had when I didn't manage to compile paraview.
So I have to ask you if you find a solution.
Actually i took paraview from this repository:

deb http://ppa.launchpad.net/cae-team/ppa/ubuntu jaunty main

because the old one doesn't work with the installation of paraview for a problem of dependencies.
Thank you
Emanuele

stomakos April 28, 2009 02:25

When I install OpenFOAM, again same problem happend... But sovled ;)

You can download Paraview from www.paraview.com and no installation is needed. Just run 'paraview' file from bin directory. When you finish your calculation in OpenFOAM just run command FoamToVTK and all your files will be read in paraview as VTK. (or VK)...

Damir

lions85 April 28, 2009 04:11

Yes, but this is not really a solution. Indeed you can change the files in vtk to open them but you can not open the entire sequence of files as in Parafoam.
Anyway I came back to ubuntu 8.10 that works fine. Maybe if a solution will be find i'll upgrade again.
Thank you
Emanuele

sxhdhi May 22, 2009 02:41

May I know the version of paraview in ubuntu 9.04 after you upgrade from 8.10 to 9.04

thanks.

Xiaohui

stomakos May 22, 2009 02:47

I made mistake, link is www.paraview.org and version is 3.4.0

hansel June 24, 2009 17:49

Quote:

Originally Posted by lions85 (Post 214212)
Hello,

The errore message is:

paraview: symbol lookup error: /usr/lib/libmpi_cxx.so.0: undefined symbol: ompi_registered_datareps

I understand that probably the problem is with the package openmpi or something similar, but i really don't know how to fix it.

Maybe i need to come back to ubuntu 8.10 formatting my computer, but i'll do it only as the last way.

COuld anyone help me?
Thank you very much
EManuele Leoni

I'm playing with the -dev version so it might not be exactly like your copy, but I found an openmpi directory in the ThirdParty directory. I built it and put the new libs in the Openfoam-1.5/libs/linux64GccDPOpt directory.

If you don't have it you could download it from www.openmpi.org. My copy was 1.2.6.

Paraview seems to look there first and I don't get the library error anymore.

Things still aren't perfect though, now it's confused about the reader.


All times are GMT -4. The time now is 18:04.