CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   paraFoam and Qt (http://www.cfd-online.com/Forums/openfoam/64585-parafoam-qt.html)

jmabna May 15, 2009 06:31

paraFoam and Qt
 
We've recently installed Qt v4.3.1 and OpenFoam v1.5 on a new linux machine. Both installations appear to have worked and the script foamInstallationTest gives the all clear for critical and basic settings.

We then tried to run the laminar flow in a cavity tutorial and all works well except paraFoam which cannot find the library libQtAssistantClient.so.4

This library is present in the Qt installation (located in /usr/local/Trolltech/....). Does an environment variable need to be set in the PATH for paraFoam to see this library? If so, does anyone know which variable and how to set it in bash?

jmabna May 15, 2009 08:09

PATH for Qt
 
With regards to my above problem, I've now seen how to set the path for Qt in my bashrc and in doing "echo $PATH" the "bin" directory in the Qt installation path is now listed.

However, when launching paraFoam for the icoFoam/cavity tutorial, I still get the same error message concerning the shared object file libQtAssitantClient.so.4 i.e. there is no such file or directory.

Any thoughts anyone and thanks for any help.

lin May 15, 2009 08:50

Read the related readme or similiar file of Qt install package.

You need to set LD_LIBRARY_PATH.

jmabna May 15, 2009 09:34

Hello Lin,

I had and the Qt assistant stated that if GCC compiler is being used one shouldn't need to extend this path. However, I have now done so and paraFoam no longer gives this error message. Thanks.

However, the new problem is now a look up error with /usr/lib64/libreadline.so.5: undefined symbol: PC

Any thoughts?

marupio May 15, 2009 19:02

Have you tried recompiling paraview and parafoam, as described in the readme? I had to try this a number of times before it finally worked...

jmabna May 18, 2009 02:55

Hello Marupio,

I'd give it a try but the script buildParaView3.3-cvs does not appear to be included in the V1.5 download. I've contacted OpenCFD and asked them to send it to me so that I can try the recompile.

Thanks.

olesen May 19, 2009 04:13

Quote:

Originally Posted by jmabna (Post 216445)
I'd give it a try but the script buildParaView3.3-cvs does not appear to be included in the V1.5 download. I've contacted OpenCFD and asked them to send it to me so that I can try the recompile.

Has it really disappear from the git repository? Hard to believe.

olesen May 19, 2009 07:06

Here's a pointer to the git repo
http://repo.or.cz/w/OpenFOAM-1.5.x.git
the build script is still there.


All times are GMT -4. The time now is 03:21.