CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   problems while invoking flex (

JObe May 18, 2009 12:26

problems while invoking flex
Hi there,

i am trying to compile OpenFOAM-1.5-dev on Scientific Linux 5, 64bit. The third party packages have successfully been compiled and linked, but starting "Allwmake" in the OpenFOAM-1.5-dev directory, i almost immediately trap into some error messages:
+ wmake libso triSurface
flex: unknown flag '-'. For usage, try
flex --help
mv: cannot stat `': No such file or directory

Does anyone have a clue?

Best regards,

dmoroian May 20, 2009 05:20

...old flex
Hi Jan,
You probably have an old version of flex.


JObe May 20, 2009 11:48

using version 2.5.4 seems to work. Thanks a lot!

dmoroian May 20, 2009 12:17

2.5.4.... uh, that's old!
According to flex website ( this version was released in 1997.
The latest version available is 2.5.35, released last year. There are some memory leaks associated with older flex versions, so it would be a good idea to update.


JObe May 20, 2009 12:32

you`re right. seems like a good idea to switch to something newer...

All times are GMT -4. The time now is 11:34.