CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

paraview 3.4 parallel error:got unknown argument p4pg

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 28, 2009, 06:18
Default paraview 3.4 parallel error:got unknown argument p4pg
  #1
New Member
 
Join Date: May 2009
Posts: 3
Rep Power: 8
carlo.dean is on a distinguished road
Hi to everybody,
I'am trying to run parview in parallel, on my computer (ubuntu 8.4).
But when I run:

- mpirun -np 2 -machinefile machines pvserver

I got this error:

got unknown argument -p4pg....

I googled this error but didn't find anything.
I used mpirun in other applications so I think there are no problem whith mpirun...
Could someone help me?
Thank You
Carlo
carlo.dean is offline   Reply With Quote

Old   June 18, 2009, 12:35
Default
  #2
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 208
Rep Power: 9
louisgag is on a distinguished road
Send a message via ICQ to louisgag
you need to compile paraview with mpi support by setting WITH_MPI=ON in the buildParaView* script
louisgag is offline   Reply With Quote

Old   June 23, 2009, 10:08
Default
  #3
New Member
 
Join Date: May 2009
Posts: 3
Rep Power: 8
carlo.dean is on a distinguished road
Thank You.
Compiling paraview setting WITH_MPI = 0 solved the problem.
But now I have another problem.
I tried to import a paralle Ensight case, but when i run it paraview seems not to load all the timesteps.
But running each part in serial mode it goes well.
What is my problem??
Is there something to specify in the .sos file for paraview???
thank you.
carlo.dean is offline   Reply With Quote

Old   June 23, 2009, 10:19
Default
  #4
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 208
Rep Power: 9
louisgag is on a distinguished road
Send a message via ICQ to louisgag
did you install the parallel plugins in paraview?

http://openfoamwiki.net/index.php/Co...r_for_ParaView

good luck with that.. took me a day, but got it working in the end..!
louisgag is offline   Reply With Quote

Old   June 23, 2009, 10:43
Default
  #5
New Member
 
Join Date: May 2009
Posts: 3
Rep Power: 8
carlo.dean is on a distinguished road
thank you for your reply.
As I can understand this reader is for the openFoam format?
My problem is with the Ensight Gold format.
this reader s for the Ensight Gold format too??
carlo.dean is offline   Reply With Quote

Old   June 23, 2009, 11:52
Default
  #6
Senior Member
 
louisgag's Avatar
 
Louis Gagnon
Join Date: Mar 2009
Location: Québec, QC, Canada
Posts: 208
Rep Power: 9
louisgag is on a distinguished road
Send a message via ICQ to louisgag
Hi Carlo,

that I don't know... You might have more luck asking on the paraview forum.

regards,

-Louis
louisgag is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xwindows crash with paraview save srinath OpenFOAM Paraview & paraFoam 1 October 15, 2008 09:37
compressible two phase flow in CFX4.4 youngan CFX 0 July 1, 2003 23:32
Mashing Problem? ji CFX 2 April 4, 2002 05:03
Error message Pandu Sattvika CFX 0 March 1, 2002 16:28


All times are GMT -4. The time now is 19:51.