CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   movingCone without stretching the mesh (http://www.cfd-online.com/Forums/openfoam/66570-movingcone-without-stretching-mesh.html)

anon_c July 19, 2009 09:04

movingCone without stretching the mesh
 
2 Attachment(s)
hello

is it posible to move the cone without strtching the mesh

with the posiblity of

Cell layer additional-removal interface

how could i reals this

and is it posible to change the speed of the motion of the cone (with timedependent motion)

timedependent form the flowtime??

Form:
init the first 2 pic and the last to pic are the end

anon_c July 19, 2009 09:16

2 Attachment(s)
soory! here are the next tow pic

henrik July 20, 2009 04:21

Dear Tajoooko,

have a look at the following tutorial in 1.5-ext

$FOAM_TUT/tutorials/icoDyMFoam/movingConeTopo

Have a look here for how to obtain 1.5-ext

http://openfoamwiki.net/index.php/Ho...M_the_easy_way

and other post on the forum.

Henrik

anon_c July 20, 2009 04:40

hello the

movingConeTopo


is not in the tutorials i instaled the openfoam-1.5 but there is this tutoral not icluded

henrik July 20, 2009 05:37

Dear Tajoooko,

you need 1.5-extend, not the 1.5 (plain, vanilla) or 1.5.x (patched vanilla, git) version, because what you want to do requires topological mesh changes.

http://www.cfd-online.com/Forums/ope...x-1-5-dev.html

Henrik

anon_c July 20, 2009 07:30

ok thank you very much danke dir ;)


now i am downloding the extended about 800MB :eek:

but i dont found an install document, to install it like an extende (erweiterung) to the openfoam

henrik July 20, 2009 07:46

Dear Tajoooko,

you are probably downloading the OpenFOAM on SLAX tar-ball which is a full operating system to put on a USB stick. It's probably not what you want, but it's very nice for beginners. Instructions are here:

http://www.cfd-online.com/Forums/ope...lax-based.html

If you are aiming for the "normal" OF-1.5-ext installation. Follow the link in my first post. There is no binary pack, so you must compile from source.

Henrik

anon_c July 20, 2009 10:35

i downloaded this and burn a cd

OpenFOAM_SLAX_noDebug.iso

and now how should i install openfoam from this iso cd???

henrik July 20, 2009 10:44

No, put it into the drive and reboot, but make sure the boot order picks up the CD first.

Henrik

anon_c July 20, 2009 11:01

ok i do that, and that is not an alternativ

i need the real openfoam-1.5-dev i will try to do that but it seems to be more difficult that the normal openfoam i get the normal openfoam quickly installed but this version is making some problemes

i would wirte here again

anon_c July 21, 2009 09:41

hello

i download

openfaom-1.5-dev and the other tgtz files form the openfoam webside

then i rename openfoam1.5-de to openfoam 1.5 and unpake the tgtz files

then i remane openfoam1.5 to openfoam 1.5-dev

then i unpake the tgtz of thirdparty and

do update my ~/.bashrc

then .$HOME/.bashrc

after that i do the installation test from openfaoam and every thing was ok

the icofoam solver and the blockMesh all was there (i just typ it in the bash)

after that i cd in the openfoam-1.5-dev and typ ./Allwmake this takes alout of time about 2 or 3 hours

and then every think was fisched

but the problem now the path dont work any more

i canot typ blockMesh or something other there is nothing more i have do cd in the directory ob bin and take them from there

what is worng??

henrik July 21, 2009 09:55

Dear Tajoooko,

Start a fresh shell and run foamInstallationTest. If it cannot be found, check your environment settings until you it's picked up.

Henrik

anon_c July 21, 2009 10:04

ammar@ammar-laptop:~$ foamInstallationTest
Executing /home/ammar/OpenFOAM/OpenFOAM-1.5-dev/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: ammar-laptop
OS: Linux version 2.6.27-14-generic
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/ammar/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/ammar/OpenFOAM/ammar-1.5-dev yes no
$WM_THIRD_PARTY_DIR /home/ammar/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/ammar/OpenFOAM/OpenFOAM-1.5-dev yes yes yes

$FOAM_APPBIN ...5-dev/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_USER_APPBIN ...5-dev/applications/bin/linuxGccDPOpt yes yes no
$WM_DIR ...mmar/OpenFOAM/OpenFOAM-1.5-dev/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.5-dev/lib/linuxGccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...FOAM/ammar-1.5-dev/lib/linuxGccDPOpt yes yes no
$MPI_ARCH_PATH ...penmpi-1.2.6/platforms/linuxGccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../src/configure
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/ammar/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_ammar-laptop Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.

henrik July 21, 2009 10:24

Dear Ammar,

The problem is here:

icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/ammar/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linuxGccDPOpt/icoFoam

I think you might have two OF installations in you PATH ...

Henrik

anon_c July 21, 2009 11:14

yeh that could be wirte bcz i tryed it with the build surce form debian but it was not good and then i thougt i geet it uninstalled

with

sudo apt-get --purge remove openfoam-dev-1.5



and then i first do install that again

but it could also be a gcc problem bcz i installed it also tow times, is there a posibility to get that problem out ?

henrik July 21, 2009 13:03

Dear Ammar,

sorry, but it seems to me that you are not taking advice and trying out alternative routes. I don't care if want to you waste your time, but I do object to wasting mine.

Please remove all those clever OF binary packages that make you life difficult. However, keep the vanilla OF 1.5 that you picked up from OpenCFD as a fall-back and in case you have trouble compiling paraFoam.

Go to the directory with the OpenFOAM-1.5 and ThirdParty directories (cd $FOAM_INST_DIR) and pull the latest OF-ext:
Code:

svn co
https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Core/OpenFOAM-1.5-dev

Then pick this up with your environment, open a fresh shell, cd $FOAM_SRC, ./Allwmake, open another fresh shell, foamInstallationTest

@GCC: Anything > 4.2.0 will be fine as long it's compatible with your system.

Henrik

anon_c July 22, 2009 02:42

I do it again on another way and now it works very fine ;) so dont be warry

and thank you very very much (danke dir sehr)


i would wirte a how to install openfoam on ubuntu 8.10 and i would wirte how to install the paraview form the apt/synaptic to geht the newist one without a problem and by one klick


All times are GMT -4. The time now is 02:05.