CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Problem with reconstructPar, please HELP (http://www.cfd-online.com/Forums/openfoam/68569-problem-reconstructpar-please-help.html)

quartzian September 24, 2009 04:03

Problem with reconstructPar, please HELP
 
Hi,

I'm running reactingFoam using a different geometry from the tutorial and GRI-Mech for the chemistry libraries.

I am able to run this in parallel, but when I try to run reconstructPar after the parallel run is over, I get this error after some time. I have output dumps every 0.001 seconds, and this goes fine until 0.007, and then at time 0.008, it fails.

I searched the forum for reconstructPar but did not find any post dealing with this. Please help.

Error below.

Thanks,

Kumar

*********************
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5 |
| \\ / A nd | Web: http://www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Exec : reconstructPar -time 0.008
Date : Sep 24 2009
Time : 12:22:16
Host : c4linux02
PID : 26596
Case : /home/OpenFOAM/OpenFOAM-1.5/work/pipeflow
nProcs : 1
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time
Create mesh for time = 0
Time = 0.008
--> FOAM Serious Error :
From function IOobject::readHeader(Istream&)
in file db/IOobject/IOobjectReadHeader.C at line 93
Reading "/home/OpenFOAM/OpenFOAM-1.5/work/pipeflow/processor0/0.008/AR" at line 1
First token could not be read or is not the keyword 'FoamFile'
Check header is of the form:
/*--------------------------------*- C++ -*----------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5 |
| \\ / A nd | Web: http://www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
FoamFile
{
version 2.0;
format ascii;
class IOobject;
location "0.008";
object AR;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Reconstructing FV fields
Reconstructing volScalarFields
CH3CHO
HCN
HCO
NNH
NCO
HNO
C2H2
C3H7
C2H3
H2O
C2H4
C2H5
C2H6
dQ
N2O
HO2
C3H8
H2
NO2
CH2WS
C2H
NH2
--> FOAM Serious Error :
From function IOobject::readHeader(Istream&)
in file db/IOobject/IOobjectReadHeader.C at line 93
Reading "/home/OpenFOAM/OpenFOAM-1.5/work/pipeflow/processor2/0.008/NH2" at line 1
First token could not be read or is not the keyword 'FoamFile'
Check header is of the form:
/*--------------------------------*- C++ -*----------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.5 |
| \\ / A nd | Web: http://www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
FoamFile
{
version 2.0;
format ascii;
class volScalarField;
location "0.008";
object NH2;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


problem while reading header for object NH2
file: /home/OpenFOAM/OpenFOAM-1.5/work/pipeflow/processor2/0.008/NH2 at line 1.
From function regIOobject::readStream(const word&)
in file db/regIOobject/regIOobjectRead.C at line 74.
FOAM exiting

quartzian September 24, 2009 07:11

Hi,

A bit more information on this. What seems to be happening is that some of the species files are missing. So, for instance in processor1/0.007, I see data for O, H2, CH4, CH3, C2H4, etc., but the file for O2 is empty, which is why the error arises.

My question is why is the file empty? The run shows no errors. So why are some of the species missing for some of the times? Is this a known bug?

Thanks very much,

Kumar


All times are GMT -4. The time now is 10:24.