CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Dummy in OpenFoam (http://www.cfd-online.com/Forums/openfoam/69208-dummy-openfoam.html)

Akuji October 15, 2009 08:51

Dummy in OpenFoam
 
hello,
I tried to do a simpleFoam in OpenFoam-1.5. But when I did main commands, I've got a mistakes. Well, I don't know openFoam, I don't know linux well, but please, if you know where I am wrong, say me. Here is what I have seen in terminal:
#0 Foam::error::printStack(Foam::Ostream&) in "/opt/OpenFOAM//OpenFOAM-1.5/lib/linux64GccDPOpt/libOpenFOAM.so"
#1 Foam::sigFpe::sigFpeHandler(int) in "/opt/OpenFOAM//OpenFOAM-1.5/lib/linux64GccDPOpt/libOpenFOAM.so"
#2 ?? in "/lib/libc.so.6"
#3 Foam::PBiCG::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const in "/opt/OpenFOAM//OpenFOAM-1.5/lib/linux64GccDPOpt/libOpenFOAM.so"
#4 Foam::fvMatrix<Foam::Vector<double> >::solve(Foam::Istream&) in "/opt/OpenFOAM//OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam"
#5 main in "/opt/OpenFOAM//OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam"
#6 __libc_start_main in "/lib/libc.so.6"
#7 Foam::regIOobject::readIfModified() in "/opt/OpenFOAM//OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam"
Floating point exception

Schag October 15, 2009 09:03

Hello,

try to be more specific: what is your case, boundary conditions, when do you get the error...

Akuji October 15, 2009 09:29

Quote:

Originally Posted by Schag (Post 232751)
Hello,

try to be more specific: what is your case, boundary conditions, when do you get the error...

example what I try to do is described in programmersguid on P-54. I did blockMesh, which has done without any problems. But when I tried to do icoFoam I had that mistake.

aunola October 16, 2009 01:42

This exercise is about simpleFoam. You seem to be running icoFoam.

Akuji October 18, 2009 16:11

Quote:

Originally Posted by aunola (Post 232834)
This exercise is about simpleFoam. You seem to be running icoFoam.

Well, at first I did blockMesh. Then icoFoam, This mistakes appeared after icoFoam, It did 34 steps. Then it said, that courant is something about 123e+129. It's abnormal...

akidess October 18, 2009 18:20

Arina, what Martin tried to say is that the tutorial isn't supposed to be run with icoFoam, but simpleFoam. So it's no surprise icoFoam doesn't converge. Try using simpleFoam instead.

Akuji October 22, 2009 09:13

Quote:

Originally Posted by akidess (Post 233125)
Arina, what Martin tried to say is that the tutorial isn't supposed to be run with icoFoam, but simpleFoam. So it's no surprise icoFoam doesn't converge. Try using simpleFoam instead.

Ye, thanks=-)
It's working

Akuji November 12, 2009 05:39

Hello.

Now I have a new problem. I tried to run parafoam and saw a mistake:
paraview: pthread_mutex_lock.c:87: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.
Aborted

Why has it appeared? And what is better to do?


All times are GMT -4. The time now is 10:27.