CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Problem with Paraview graphics (http://www.cfd-online.com/Forums/openfoam/69610-problem-paraview-graphics.html)

Ronnfors October 28, 2009 13:55

Problem with Paraview graphics
 
Hi,

First I had problems with Qt on Ubuntu 9.04, common problem ;)

When finally managed to start paraview I get no image of the domain for the first tutorial with the cavity.

It seems to be graphic problem and I try to use envyng to get my drivers. What happends is that Ubuntu freeze at log in and I have to reinstall ( I am a new user, perhaps there is some way around it).

Even if this is not a direct CFD question, it really concerns my ability to work with the software.

Is there anyone out there having the same problem or had the problem?
My graphics card is ATI Radeon 9200 M2+ and I my computer is AMD 3200+ 64 bit

Thanks!

tachyon_me October 30, 2009 16:41

For me ATI has trouble on ubuntu 9.04, I changed it to nVidia everything works ...

Thomas Baumann November 2, 2009 05:59

Hallo,

use the command foamToVTK to convert the simulation-data to VTK format.

Afterwards open paraview and open the VTK-data.

Regards Thomas

demichie November 2, 2009 07:30

Quote:

Originally Posted by Ronnfors (Post 234385)
Hi,

First I had problems with Qt on Ubuntu 9.04, common problem ;)

When finally managed to start paraview I get no image of the domain for the first tutorial with the cavity.

Thanks!

It could be a language related problem (what is your Ubuntu installation language?).
Try to add this line at the beginning of your paraFoam script in the bin folder:

"export LC_ALL=C"


ciao
mattia

franzisko November 3, 2009 11:47

graphic drivers
 
did u solve the problem about paraview?
I would try setting vesa driver for graphic card
in the file
/etc/X11/xorg.conf
in the section device put
Driver "Vesa"

f.

Ronnfors November 3, 2009 12:04

Hi!

Thank you all for you suggestions!

It didnt work to use envyng.

"
It could be a language related problem (what is your Ubuntu installation language?).
Try to add this line at the beginning of your paraFoam script in the bin folder:

"export LC_ALL=C"
"

The text above I didn not really understand but I will try it.

I will try to set the driver to VESA. The problem I have is that in the view window in paraview I can click and rotate, then I see the x,y,z coordinate system but as soon as I release the mouse button, it turns gray again.

Thanks again! I will get back with update!

Ronnfors November 4, 2009 08:39

Quote:

Originally Posted by franzisko (Post 234975)
did u solve the problem about paraview?
I would try setting vesa driver for graphic card
in the file
/etc/X11/xorg.conf
in the section device put
Driver "Vesa"

f.

I tried the export LC and no improvement on graphics. I can see my geometry if I rotate it but it flashes.

Question to Franzisko, if I input vesa in the driver section. Is there a risk that I get problems with starting Ubuntu, like a frozen log in? I got this when I tried the envyng and I had to reinstall. Thanks!

Ronnfors November 4, 2009 09:50

Quote:

Originally Posted by franzisko (Post 234975)
did u solve the problem about paraview?
I would try setting vesa driver for graphic card
in the file
/etc/X11/xorg.conf
in the section device put
Driver "Vesa"

f.

Hi!
It works :)
Thank you very much for your help!!

The only problem is that I get very low resolution with only 256 colors. Do you know what to do about that?

Thank you!

franzisko November 4, 2009 13:49

i dont know but I am interested in...
 
hello,

I cant fix the resolution problem. actually I dont know how many colors I am using... I would say that it is slow in 3d rendering but i dont know if the problem is vesa driver. let me know if you find a better solution, anyway nvidia seems better for ubuntu, I have the same problem as you. consider that people have the same problem using salome' software, hence you can find help in such forums,

bye, Francesco


All times are GMT -4. The time now is 19:17.