CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

QT4 assiatant installation

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 14, 2009, 08:43
Default QT4 assiatant installation
  #1
New Member
 
Join Date: Nov 2009
Posts: 6
Rep Power: 7
aliakbar82 is on a distinguished road
I want to install OpenFOAM 1.6 H have done evey thinh ountill the part i shoude install QT4 assiatant but this computer that i work with can not connect to internet and its installation needs connecting to internet. So I do not how to downloal QT4 assiatant using another computer and how to install it to solve my problem.
aliakbar82 is offline   Reply With Quote

Old   November 15, 2009, 03:29
Default
  #2
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 382
Rep Power: 9
gwierink is on a distinguished road
  • You can get the Qt-4.3.5 source from here
  • Download it, copy it to the computer you need it on
  • Then unpack it
    Code:
    tar -xzf qt-x11-opensource-src-4.3.5.tar.gz
  • Configure Qt
    Code:
    ./configure
  • Make Qt (as root)
    Code:
    make
  • And install it
    Code:
    make install
gwierink is offline   Reply With Quote

Old   November 16, 2009, 03:02
Default qt installation
  #3
New Member
 
Join Date: Nov 2009
Posts: 6
Rep Power: 7
aliakbar82 is on a distinguished road
Thank you for answer but it does not work completely.I did all you said ,unpacking Qt-4.3.5 then Configuring Qt,but when I ran make command I saw a lot of warnings and erors such as:

../../include/QtCore/../../src/corelib/tools/qbytearray.h:398: warning: type qualifiers ignored on function return t
../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:310: error: ‘Window’ has not been declared
make[1]: *** [.obj/release-shared/qapplication.o] Error 1
make[1]: Leaving directory `/home/ali/qt-x11-opensource-src-4.3.5/src/gui'
make: *** [sub-gui-make_default-ordered] Error 2

but after them I ran make install and this messages appeared:
mkdir: cannot create directory `/usr/local/Trolltech': Permission denied

make[1]: *** [install_target] Error 1

make[1]: Leaving directory `/home/ali/qt-x11-opensource-src-4.3.5/src/tools/moc'

make: *** [sub-moc-install_subtargets-ordered] Error 2

I dont know how to solve this problem.who can help me?
aliakbar82 is offline   Reply With Quote

Old   November 16, 2009, 13:12
Default
  #4
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 382
Rep Power: 9
gwierink is on a distinguished road
Quote:
/usr/local/Trolltech': Permission denied
You get that message because your user (you) does not have write permission in /usr/local/... You need to be root for that, i.e. type "su" before "make" and "make install" (or "sudo make" and "sudo make install" I guess) and give your root password.
gwierink is offline   Reply With Quote

Old   July 23, 2012, 15:24
Default hi
  #5
New Member
 
Sajjad baraty
Join Date: Jun 2012
Posts: 2
Rep Power: 0
Sajjad_Baraty is on a distinguished road
i have this problem.please help
Sajjad_Baraty is offline   Reply With Quote

Old   July 23, 2012, 16:47
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Sajjad Baraty and welcome to the forum!

Quote:
Originally Posted by Sajjad_Baraty View Post
i have this problem.please help
Please provide more details:
  1. What Linux distribution are you using?
  2. What exact error message are you getting?
  3. Which instructions have you followed?
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 23, 2012, 17:52
Default
  #7
New Member
 
Sajjad baraty
Join Date: Jun 2012
Posts: 2
Rep Power: 0
Sajjad_Baraty is on a distinguished road
thank you.
i use fedora 16.
and the exact error is (the 2 last line) :
make[1]: *** [.obj/release-shared/qsslcertificate.o] Error 1
make[1]: Leaving directory `/home/sajjad/OpenFOAM/ThirdParty-2.1.0/qt-x11-opensource-src-4.3.5/src/network'
make: *** [sub-network-install_subtargets-ordered] Error 2
Sajjad_Baraty is offline   Reply With Quote

Old   July 23, 2012, 18:16
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
The instructions on this thread are seriously outdated if you are using Fedora 16 and OpenFOAM 2.1.0.
Here more recent instructions, although they are also becoming outdated by now: Building ParaView 3.10.1 with custom Qt 4.6.4
Adapt where necessary for using ParaView 3.12.0, but I advise you to still use Qt 4.6.4.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 18:56
Installation problems indy OpenFOAM Installation 7 April 3, 2009 09:40
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Problems with installation of OpenFoam sheyer OpenFOAM Installation 8 July 28, 2008 03:45
Installation problems shellbell1999 OpenFOAM Installation 9 April 6, 2006 13:29


All times are GMT -4. The time now is 20:44.