CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

snappyHexMesh error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 16, 2009, 19:17
Default snappyHexMesh error
  #1
New Member
 
Ted Brenner
Join Date: Oct 2009
Location: Oregon, WI
Posts: 12
Rep Power: 7
griztown is on a distinguished road
Hi all,

I'm running snappyHexMesh to create a mesh around a body I have and I get the following error:

--> FOAM Warning :
From function treeBoundBox::treeBoundBox(const UList<point>&, const UList<label>&)
in file octree/treeBoundBox.C at line 157
cannot find bounding box for zero-sized pointFieldreturning zero

I'm having a hard time figuring out where this problem is coming from. Everything was working great with a similar geometry, but now with a new stl file, I'm getting this error. Any ideas on where I should be looking? The error comes up while determining initial surface intersections. Looking through the stl file and the block mesh, there shouldn't be any problems finding an intersection.

Any help is greatly appreciated.
griztown is offline   Reply With Quote

Old   November 17, 2009, 15:06
Default
  #2
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 214
Rep Power: 9
fra76 is on a distinguished road
It looks like a problem in your stl file, like a triangle with three coincident points or something like this.
Which version of OpenFOAM are you using? Something has been improved in the 1.6.x.

Francesco
fra76 is offline   Reply With Quote

Old   November 17, 2009, 15:08
Default
  #3
New Member
 
Ted Brenner
Join Date: Oct 2009
Location: Oregon, WI
Posts: 12
Rep Power: 7
griztown is on a distinguished road
Thanks Francesco,

I'm running 1.6.x. I'll look into the stl file some more. Thanks for the tip!
griztown is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 01:33.