CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Problem with paraFoam (http://www.cfd-online.com/Forums/openfoam/70185-problem-parafoam.html)

ata November 17, 2009 01:15

Problem with paraFoam
 
Hi foamers
I have som problem with paraFoam. When I run it I get this message:
"created temporary 'cavity.OpenFOAM'
/home/ata/OpenFOAM/OpenFOAM-1.6/bin/paraFoam: 132: paraview: not found"
Can any one help me?
Thanks

Ata

ata November 17, 2009 01:30

Problem with paraFoam
 
Hi
I try to recompile paraView from source but when I run makeParaViewI get this message:
"command not found"
My qt version is "QMake version 2.01a, Using Qt version 4.3.4 in /usr/lib"
Can any one help me?
Thanks

Ata

wyldckat November 17, 2009 09:22

Greetings Ata,

Well, you'll need at least Qt 4.3.5 to get things going. So, please follow the instructions available here for Qt and here for Paraview!.

Best regards,
Bruno

ata November 18, 2009 01:42

Hello Bruno
Thanks for your reply. My qt version is 4.3.4 is it low?
When I try makeParaView in spite of the fact that the makeParaView exists in related folder but I got this message "command not found"
Can you or any one help me?
Thanks allot

Ata

wyldckat November 18, 2009 09:55

Hello Ata,

I forgot to comment about that... to run scripts from a local folder, usually you have to use "./". For your case:
Code:

./makeParaView
I know, it's a bit weird, but that's how it works.
Don't forget to follow the instructions I left on the other post!

Best regards,
Bruno

ata November 21, 2009 01:54

Problem with paraFoam
 
Hello Bruno
Thank you very much. I am trying. It takes much time to "./makeParaView". I'll inform you.
Thanks allot

Ata

ata November 21, 2009 08:05

Problem with paraFoam
 
Hello Bruno
Thanks for your reply.
I run ./makeParaView after couple of hours it don.First time paraview run but not correctly. It's weird but menus and screen disappeared chaotic. When I restart my computer and run it for second time first its starting window come on but after few seconds I got this message in terminal:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 405
vtkXOpenGLRenderWindow (0x88d8ec8): Could not find a decent visual



Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 405
vtkXOpenGLRenderWindow (0x88d8ec8): Could not find a decent visual



ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 612
vtkXOpenGLRenderWindow (0x88d8ec8): GLX not found. Aborting.


Aborted

Can you or any body help me?

Thanks allot

Ata

andy_ November 21, 2009 08:29

Quote:

Originally Posted by ata (Post 237149)

Can you or any body help me?

It is telling you that it cannot set your computer to an acceptable OpenGL mode. This may be because you have very old graphics hardware with poor OpenGL support or because you have not yet installed on your system some of the required OpenGL software. What computer are using and what operating system?

ata November 21, 2009 08:49

Problem with ParaView
 
Hello andy
Thanks for your reply

My computer is:
CPU:Intel Celeron 2.40GHz
VGA:RADEON 7000
RAM: 512 MB

My operating system is ubuntu 8.04

Thanks

Ata

andy_ November 21, 2009 10:45

That looks like an ATI graphics card. You probably need to install the linux opengl glx software for your card. For NVIDIA cards these are identifiable software packages in synaptic which you can simply select and install. I don't know about ATI cards and so would suggest checking the ATI site for linux/opengl support and browsing synaptic for a likely looking generic opengl glx package.

ata November 21, 2009 13:42

Priblem with paraview
 
Hello Andy
Thank you very much
Best regards

Ata

ata November 29, 2009 03:10

Problem with paraview
 
Hi foamers
When I installed paraview on a new computer via synaptick pakage manager an run I got this error:
paraview: /home/ata/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/paraview/libvtksys.so.pv3.4)
Can any one help me?
Regards

Ata

ata November 29, 2009 05:45

Hi foamers
When I compile paraview on a new computer it worked but I got this message in terminal:
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
Generic Warning: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Filtering/vtkPolyLine.cxx, line 196
Coincident points in polyline...can't compute normals


X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693

When I get screen shot in paravie I get this message:

X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693


Can any one help me?
Regards

Ata

wyldckat November 29, 2009 19:01

Hello Ata,

Ouch, you're not having much luck with Paraview...
Quote:

paraview: /home/ata/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/paraview/libvtksys.so.pv3.4)
One solution can be found here.

As for your latest problem, try what I've already said in this thread.

And did you try the same solution you used with the other machine, the one you had in post #9?

Best regards,
Bruno

ata November 30, 2009 05:23

Priblem with paraview
 
Hi Bruno
Thank you very much. No I got this error on an other machine.
Best Regards

Ata


All times are GMT -4. The time now is 08:25.