CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Problem with paraFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 17, 2009, 01:15
Default Problem with paraFoam
  #1
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hi foamers
I have som problem with paraFoam. When I run it I get this message:
"created temporary 'cavity.OpenFOAM'
/home/ata/OpenFOAM/OpenFOAM-1.6/bin/paraFoam: 132: paraview: not found"
Can any one help me?
Thanks

Ata
ata is offline   Reply With Quote

Old   November 17, 2009, 01:30
Default Problem with paraFoam
  #2
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hi
I try to recompile paraView from source but when I run makeParaViewI get this message:
"command not found"
My qt version is "QMake version 2.01a, Using Qt version 4.3.4 in /usr/lib"
Can any one help me?
Thanks

Ata
ata is offline   Reply With Quote

Old   November 17, 2009, 09:22
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Ata,

Well, you'll need at least Qt 4.3.5 to get things going. So, please follow the instructions available here for Qt and here for Paraview!.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 18, 2009, 01:42
Default
  #4
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hello Bruno
Thanks for your reply. My qt version is 4.3.4 is it low?
When I try makeParaView in spite of the fact that the makeParaView exists in related folder but I got this message "command not found"
Can you or any one help me?
Thanks allot

Ata
ata is offline   Reply With Quote

Old   November 18, 2009, 09:55
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hello Ata,

I forgot to comment about that... to run scripts from a local folder, usually you have to use "./". For your case:
Code:
./makeParaView
I know, it's a bit weird, but that's how it works.
Don't forget to follow the instructions I left on the other post!

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 21, 2009, 01:54
Default Problem with paraFoam
  #6
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hello Bruno
Thank you very much. I am trying. It takes much time to "./makeParaView". I'll inform you.
Thanks allot

Ata
ata is offline   Reply With Quote

Old   November 21, 2009, 08:05
Default Problem with paraFoam
  #7
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hello Bruno
Thanks for your reply.
I run ./makeParaView after couple of hours it don.First time paraview run but not correctly. It's weird but menus and screen disappeared chaotic. When I restart my computer and run it for second time first its starting window come on but after few seconds I got this message in terminal:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 405
vtkXOpenGLRenderWindow (0x88d8ec8): Could not find a decent visual



Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 405
vtkXOpenGLRenderWindow (0x88d8ec8): Could not find a decent visual



ERROR: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 612
vtkXOpenGLRenderWindow (0x88d8ec8): GLX not found. Aborting.


Aborted

Can you or any body help me?

Thanks allot

Ata
ata is offline   Reply With Quote

Old   November 21, 2009, 08:29
Default
  #8
Senior Member
 
andy
Join Date: May 2009
Posts: 129
Rep Power: 8
andy_ is on a distinguished road
Quote:
Originally Posted by ata View Post

Can you or any body help me?
It is telling you that it cannot set your computer to an acceptable OpenGL mode. This may be because you have very old graphics hardware with poor OpenGL support or because you have not yet installed on your system some of the required OpenGL software. What computer are using and what operating system?
andy_ is offline   Reply With Quote

Old   November 21, 2009, 08:49
Default Problem with ParaView
  #9
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hello andy
Thanks for your reply

My computer is:
CPU:Intel Celeron 2.40GHz
VGA:RADEON 7000
RAM: 512 MB

My operating system is ubuntu 8.04

Thanks

Ata
ata is offline   Reply With Quote

Old   November 21, 2009, 10:45
Default
  #10
Senior Member
 
andy
Join Date: May 2009
Posts: 129
Rep Power: 8
andy_ is on a distinguished road
That looks like an ATI graphics card. You probably need to install the linux opengl glx software for your card. For NVIDIA cards these are identifiable software packages in synaptic which you can simply select and install. I don't know about ATI cards and so would suggest checking the ATI site for linux/opengl support and browsing synaptic for a likely looking generic opengl glx package.
andy_ is offline   Reply With Quote

Old   November 21, 2009, 13:42
Default Priblem with paraview
  #11
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hello Andy
Thank you very much
Best regards

Ata
ata is offline   Reply With Quote

Old   November 29, 2009, 03:10
Default Problem with paraview
  #12
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hi foamers
When I installed paraview on a new computer via synaptick pakage manager an run I got this error:
paraview: /home/ata/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/paraview/libvtksys.so.pv3.4)
Can any one help me?
Regards

Ata
ata is offline   Reply With Quote

Old   November 29, 2009, 05:45
Default
  #13
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hi foamers
When I compile paraview on a new computer it worked but I got this message in terminal:
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693
Generic Warning: In /home/ata/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/VTK/Filtering/vtkPolyLine.cxx, line 196
Coincident points in polyline...can't compute normals


X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693

When I get screen shot in paravie I get this message:

X Error: GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x4600693


Can any one help me?
Regards

Ata

Last edited by ata; November 29, 2009 at 06:01.
ata is offline   Reply With Quote

Old   November 29, 2009, 19:01
Default
  #14
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hello Ata,

Ouch, you're not having much luck with Paraview...
Quote:
paraview: /home/ata/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/paraview/libvtksys.so.pv3.4)
One solution can be found here.

As for your latest problem, try what I've already said in this thread.

And did you try the same solution you used with the other machine, the one you had in post #9?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 30, 2009, 05:23
Default Priblem with paraview
  #15
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 8
ata is on a distinguished road
Hi Bruno
Thank you very much. No I got this error on an other machine.
Best Regards

Ata
ata is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF compiling problem Wouter Fluent UDF and Scheme Programming 6 June 6, 2012 04:43
paraFoam problem autumn1012 OpenFOAM Paraview & paraFoam 22 July 8, 2010 02:20
natural convection problem for a CHT problem Se-Hee CFX 2 June 10, 2007 06:29
Adiabatic and Rotating wall (Convection problem) ParodDav CFX 5 April 29, 2007 19:13
Is this problem well posed? Thomas P. Abraham Main CFD Forum 5 September 8, 1999 14:52


All times are GMT -4. The time now is 07:29.