CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Please help - error after recompiling thermophysical models

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 31, 2009, 11:21
Question Please help - error after recompiling thermophysical models
  #1
New Member
 
Axel Tietjen
Join Date: Dec 2009
Location: Hamburg, Germany
Posts: 19
Rep Power: 7
Axel_T is on a distinguished road
Dear Foam users,

I have just 4 weeks left to finish my diploma thesis about OpenFoam and it seems that I accidently ruined my OpenFOAM installation.
Running short of time, I hope someone can give me a quick solution to fix the problem. But here is the whole story:

After I got a bit to often terminated solutions with error-messages like "maximum number of equations exceeded", I wanted to try to change that value in the source files.

I found that value in
/home/axel/OpenFOAM/OpenFOAM-1.6.x/src/thermophysicalModels/specie/lnInclude/specieThermo.C
and changed it.

To "activate" those modifications, the code must be compiled again (I hope I'm at least right in this point), so I executed
wmake libso specie
as I found that command in the /src/thermophysicalModells/Allwmake file.

Now there is allways the following error message when I execute a rhoPisoFoam Simulation:
Creating turbulence model

Selecting turbulence model type RASModel
Selecting RAS turbulence model kOmegaSST
new cannot satisfy memory request.
This does not necessarily mean you have run out of virtual memory.
It could be due to a stack violation caused by e.g. bad use of pointers or an out of date shared library
It's the same when I use kEpsilon turbulence model, but when I use for example icoFoam, which doesn't use a turbulence model it runs without error.

My first Idea was to recompile the turbulence files, too. With no success.
Then I took back all modifications and recompiled everything in the original state. Didn't help, too.

As anyone some ideas, how I can repair my OpenFOAM installation?
I'd appreciate any hints.

Thanks, (and btw a happy new year!)
Axel
Axel_T is offline   Reply With Quote

Old   January 5, 2010, 09:24
Default unsolved but obsolete
  #2
New Member
 
Axel Tietjen
Join Date: Dec 2009
Location: Hamburg, Germany
Posts: 19
Rep Power: 7
Axel_T is on a distinguished road
Hello to everyone,

the problem is still unsolved, but since I re-installed my computer and OpenFOAM, the error doesn't appear anymore, of course.

I've learned my lesson, and from now on, I'll never touch the source-files again.

greetings
Axel
Axel_T is offline   Reply With Quote

Reply

Tags
change source files, maximum number, recompile, stack violation

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two-fluid models vs mixture models for bubbly flows Hansong Tang Main CFD Forum 6 December 8, 2009 04:21
MODELS Murthy V N FLUENT 0 February 9, 2008 02:48
informaiton about k-omega models krisreddi CFX 2 August 10, 2005 06:53
How to set phase dependent turbulence models? J.Yang CFX 2 August 29, 2002 15:39
CFD models Xie Main CFD Forum 0 April 18, 2002 13:48


All times are GMT -4. The time now is 09:42.