CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

interFoam error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 12, 2010, 23:21
Default interFoam error
  #1
Member
 
Join Date: Dec 2009
Posts: 46
Rep Power: 7
openfoam1 is on a distinguished road
hi guys

I'm trying to solve 2 phase flow using inter foam and i got that error

FOAM FATAL ERROR:
This mesh contains patches of type empty but is not 1D or 2D
by virtue of the fact that the number of faces of this
empty patch is not divisible by the number of cells
.


i have many blocks and i use mergePatchPairs exactilly as in breaking of dam tutorial

mergePatchPairs
(
);


but i don't know why that error , any one have any idea
thanks
openfoam1 is offline   Reply With Quote

Old   January 13, 2010, 04:44
Default
  #2
Senior Member
 
Jens Höpken
Join Date: Apr 2009
Location: Duisburg, Germany
Posts: 156
Rep Power: 8
jhoepken is on a distinguished road
Send a message via Skype™ to jhoepken
Hi,

As a quick guess, I would suggest to check your constant/polyMesh/boundary file for any patches of type empty. I guess, you have a 3D mesh? Then it is not valid to use patches of type empty for your mesh.
jhoepken is offline   Reply With Quote

Old   January 13, 2010, 06:11
Default interFoam
  #3
Senior Member
 
NAVEEN.K.M
Join Date: Mar 2009
Location: Bangalore, Karnataka, india
Posts: 114
Rep Power: 8
naveen is on a distinguished road
hi openfoam1,

i think u hav not specified the boundary conditions like inlet, outlet,wall etc in fields...dont leave empty boundary conditions in inlet,outlet and wall except 3D
naveen is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 11:05.