CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Abort->Changing from Euler to Backward -> Running (http://www.cfd-online.com/Forums/openfoam/72957-abort-changing-euler-backward-running.html)

idrama February 23, 2010 04:05

Abort->Changing from Euler to Backward -> Running
 
Hey Foamers!

Has anybody made the following experience:
1) simulation stops due to an error at time t_1,
2) restart from latest time the simulation stops with the same error at t_1
3) changing Euler to backward
4) simulation works fine and passes the t_1.

After a while there error stop at t_2. Same procedure, but switching from backward of Euler. Thats funny. Has anybody an idea or an explanation for that.

Cheers,

Claus

djbungee February 25, 2010 13:01

Hi Claus,

some more details would be helpful.

What kind of error? Divergence? How did you initialize your fields and what setup did you use?

I fear that without these details one cannot reproduce or really understand what happened in your case. You should provide the complete case setup, if possible.

Best regards, Ulf.

idrama February 25, 2010 13:35

Hello Ulf,

the computationa domain is a pipe with an timevaryingfixeduniformvalue, i.e. at the beginning at the inlet there is velocity of 9.8 m/s and at time 0.6s the inlet will be turned off. The transition is carry out by a smooth function, i.e. i generated a file for these kind of boundary to mange the transition. Addtionally, not the velocity is turning to zero also the values for k and epsilon, however not exatly zero due to stability. Until the turn off at 0.6 everytings runs fine even until 0.8. But then the solution stops suddenly with an error in pressure. The inresting thing is there are no suspicions in the log file history.

cheers

djbungee March 4, 2010 06:07

Hi Claus,

ok, this does not really help (me) to understand the problem. With complete setup I was thinking about all files needed to compute the case to reproduce the error.

I hope that someone else can help you....

Best regards, Ulf.


All times are GMT -4. The time now is 16:07.