CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Abort->Changing from Euler to Backward -> Running

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 23, 2010, 04:05
Default Abort->Changing from Euler to Backward -> Running
  #1
Senior Member
 
Claus Meister
Join Date: Aug 2009
Location: Wiesbaden, Germany
Posts: 241
Rep Power: 9
idrama is on a distinguished road
Hey Foamers!

Has anybody made the following experience:
1) simulation stops due to an error at time t_1,
2) restart from latest time the simulation stops with the same error at t_1
3) changing Euler to backward
4) simulation works fine and passes the t_1.

After a while there error stop at t_2. Same procedure, but switching from backward of Euler. Thats funny. Has anybody an idea or an explanation for that.

Cheers,

Claus
idrama is offline   Reply With Quote

Old   February 25, 2010, 13:01
Question
  #2
Member
 
djbungee's Avatar
 
Ulf Bunge
Join Date: Mar 2009
Location: Wolfsburg, Germany
Posts: 34
Rep Power: 8
djbungee is on a distinguished road
Hi Claus,

some more details would be helpful.

What kind of error? Divergence? How did you initialize your fields and what setup did you use?

I fear that without these details one cannot reproduce or really understand what happened in your case. You should provide the complete case setup, if possible.

Best regards, Ulf.
djbungee is offline   Reply With Quote

Old   February 25, 2010, 13:35
Default
  #3
Senior Member
 
Claus Meister
Join Date: Aug 2009
Location: Wiesbaden, Germany
Posts: 241
Rep Power: 9
idrama is on a distinguished road
Hello Ulf,

the computationa domain is a pipe with an timevaryingfixeduniformvalue, i.e. at the beginning at the inlet there is velocity of 9.8 m/s and at time 0.6s the inlet will be turned off. The transition is carry out by a smooth function, i.e. i generated a file for these kind of boundary to mange the transition. Addtionally, not the velocity is turning to zero also the values for k and epsilon, however not exatly zero due to stability. Until the turn off at 0.6 everytings runs fine even until 0.8. But then the solution stops suddenly with an error in pressure. The inresting thing is there are no suspicions in the log file history.

cheers
idrama is offline   Reply With Quote

Old   March 4, 2010, 06:07
Default
  #4
Member
 
djbungee's Avatar
 
Ulf Bunge
Join Date: Mar 2009
Location: Wolfsburg, Germany
Posts: 34
Rep Power: 8
djbungee is on a distinguished road
Hi Claus,

ok, this does not really help (me) to understand the problem. With complete setup I was thinking about all files needed to compute the case to reproduce the error.

I hope that someone else can help you....

Best regards, Ulf.
djbungee is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backward Euler smagmon CFX 3 April 16, 2009 08:10
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52
Forward and Backward Euler. Question Man. Main CFD Forum 2 March 29, 2004 13:19


All times are GMT -4. The time now is 16:39.