CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM

paraFoam problem (Qt update)

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 28, 2010, 10:58
Lightbulb paraFoam problem (Qt update)
  #1
Senior Member
 
maysmech's Avatar
 
Maysam
Join Date: Jan 2010
Posts: 344
Blog Entries: 2
Rep Power: 7
maysmech is on a distinguished road
Dear FOAMers
hi
i have fedora 12 and installed OpenFOAM 1.6.

My problem is when typing paraFoam this error is seen:


Code:
created temporary 'cavity.OpenFOAM'
/home/maysam/OpenFOAM/ThirdParty-1.6/paraview-3.6.1/platforms/linux64Gcc/bin/paraview-real: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
i found i should update my Qt but i don't know how?
my qt version is:
Code:
Qmake version: 1.07a (Qt 3.3.8b)
maysmech is offline   Reply With Quote

Old   February 28, 2010, 12:08
Default
  #2
Member
 
MSR CHANDRA MURTHY
Join Date: Mar 2009
Posts: 30
Rep Power: 7
chandramurthy is on a distinguished road
try the following bash commands

su -c 'yum install qt4-qmake'
su -c 'ln -s /usr/bin/qmake-qt4 /usr/bin/qmake'

give root password
chandramurthy is offline   Reply With Quote

Old   February 28, 2010, 12:38
Default
  #3
Senior Member
 
maysmech's Avatar
 
Maysam
Join Date: Jan 2010
Posts: 344
Blog Entries: 2
Rep Power: 7
maysmech is on a distinguished road
Quote:
Originally Posted by chandramurthy View Post
try the following bash commands
No result...
maysmech is offline   Reply With Quote

Old   March 1, 2010, 05:34
Default
  #4
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 13
l_r_mcglashan will become famous soon enough
I had this problem as well: I use Fedora 12 too.
There were a number of problems I had, I recall with paraview having to remake it and the reader utility in order for it to work. Have you tried that?

I also remember this error with libssl. Try 'locate libssl' and see where it exists. I remember putting a softlink in sorted it out fine.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   March 1, 2010, 10:30
Default solved
  #5
Senior Member
 
maysmech's Avatar
 
Maysam
Join Date: Jan 2010
Posts: 344
Blog Entries: 2
Rep Power: 7
maysmech is on a distinguished road
my problem was solved.
i update my Qt version by typing this command:

Code:
su -c 'yum update qt'
maysmech is offline   Reply With Quote

Old   March 2, 2010, 07:08
Default
  #6
New Member
 
Karin Axelsson
Join Date: Feb 2010
Posts: 11
Rep Power: 6
ka1184 is on a distinguished road
I have exactly the same problem (old version of Qt) but I'm using Redhat.
Are there any similar commands that I can use to update my version to Qt4?
ka1184 is offline   Reply With Quote

Reply

Tags
fedora 12, libssl, qt update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF compiling problem Wouter Fluent UDF and Scheme Programming 6 June 6, 2012 05:43
Problem with paraFoam (ubuntu 9.04) peb OpenFOAM Paraview & paraFoam 4 August 24, 2009 10:50
problem with running parafoam & paraview padmanathan OpenFOAM 3 June 12, 2009 08:30
natural convection problem for a CHT problem Se-Hee CFX 2 June 10, 2007 07:29
Adiabatic and Rotating wall (Convection problem) ParodDav CFX 5 April 29, 2007 20:13


All times are GMT -4. The time now is 02:44.