CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   ParaView and Qt 4.3.5 on Mac OS X 10.6 (http://www.cfd-online.com/Forums/openfoam/74297-paraview-qt-4-3-5-mac-os-x-10-6-a.html)

Adrian March 29, 2010 17:02

ParaView and Qt 4.3.5 on Mac OS X 10.6
 
Hello everyone

I have problems to get ParaView compiled on my MacBook Pro.

When I run makeParaView I get the Error

#error "You are building a 64-bit application, but using a 32-bit version of Qt. Check your build configuration."


I have installed Qt 4.6.2 which might be the problem (?). But when I try to install Qt 4.3.5 I get

#error "This version of Mac OS X is unsupported"


I would really appreciate if someone could help me with that.
Below are the two errors n a bit a longer version.

Cheers Adrian



Code:

[  1%] Building C object VTK/Utilities/vtkfreetype/CMakeFiles/vtkfreetype.dir/src/base/ftbase.o
In file included from /System/Library/Frameworks/CoreFoundation.framework/Headers/CoreFoundation.h:43,
                from /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/CarbonCore.h:20,
                from /System/Library/Frameworks/CoreServices.framework/Frameworks/AE.framework/Headers/AE.h:20,
                from /System/Library/Frameworks/CoreServices.framework/Headers/CoreServices.h:21,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/VTK/Utilities/vtkfreetype/src/base/ftmac.c:85,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/VTK/Utilities/vtkfreetype/src/base/ftbase.c:35:
/System/Library/Frameworks/CoreFoundation.framework/Headers/CFBundle.h:147: error: format string argument not a string type
make[2]: *** [VTK/Utilities/vtkfreetype/CMakeFiles/vtkfreetype.dir/src/base/ftbase.o] Error 1
make[1]: *** [VTK/Utilities/vtkfreetype/CMakeFiles/vtkfreetype.dir/all] Error 2
make: *** [all] Error 2

real        1m15.677s
user        0m36.215s
sys        0m6.295s
    Done make
    For quicker development, linking lib/paraview-3.6/ -> bin/
    Creating html documentation
[  0%] Generating qrc_pqChart.cxx
[  0%] Generating moc_pqChartArea.cxx
[  0%] Generating moc_pqChartAxis.cxx
[  0%] Generating moc_pqChartAxisModel.cxx
[  0%] Generating moc_pqChartAxisOptions.cxx
[  0%] Generating moc_pqChartContentsSpace.cxx
[  0%] Generating moc_pqChartInteractor.cxx
[  0%] Generating moc_pqChartLegend.cxx
[  0%] Generating moc_pqChartLegendModel.cxx
[  1%] Generating moc_pqChartLayer.cxx
[  1%] Generating moc_pqChartMouseFunction.cxx
[  1%] Generating moc_pqChartMouseSelection.cxx
[  1%] Generating moc_pqChartPlugin.cxx
[  1%] Generating moc_pqChartTitle.cxx
[  1%] Generating moc_pqChartValueFormatter.cxx
[  1%] Generating moc_pqChartWidget.cxx
[  1%] Generating moc_pqChartWidgetPlugin.cxx
[  1%] Generating moc_pqColorMapColorChanger.cxx
[  1%] Generating moc_pqColorMapModel.cxx
[  1%] Generating moc_pqColorMapWidget.cxx
[  1%] Generating moc_pqColorMapWidgetPlugin.cxx
[  1%] Generating moc_pqHistogramChart.cxx
[  1%] Generating moc_pqHistogramChartOptions.cxx
[  1%] Generating moc_pqHistogramModel.cxx
[  1%] Generating moc_pqHistogramSelectionModel.cxx
[  1%] Generating moc_pqLineChart.cxx
[  1%] Generating moc_pqLineChartModel.cxx
[  1%] Generating moc_pqLineChartOptions.cxx
[  1%] Generating moc_pqLineChartSeries.cxx
[  1%] Generating moc_pqLineChartSeriesOptions.cxx
[  1%] Generating moc_pqSimpleHistogramModel.cxx
Scanning dependencies of target QtChart
[  1%] Building CXX object Qt/Chart/CMakeFiles/QtChart.dir/pqChartArea.o
In file included from /Library/Frameworks/QtCore.framework/Headers/qnamespace.h:45,
                from /Library/Frameworks/QtCore.framework/Headers/qobjectdefs.h:45,
                from /Library/Frameworks/QtGui.framework/Headers/qwindowdefs.h:45,
                from /Library/Frameworks/QtGui.framework/Headers/qwidget.h:45,
                from /Library/Frameworks/QtGui.framework/Headers/QWidget:1,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/Qt/Chart/pqChartArea.h:41,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/Qt/Chart/pqChartArea.cxx:36:
/Library/Frameworks/QtCore.framework/Headers/qglobal.h:288:2: error: #error "You are building a 64-bit application, but using a 32-bit version of Qt. Check your build configuration."
In file included from /Library/Frameworks/QtGui.framework/Headers/qmatrix.h:46,
                from /Library/Frameworks/QtGui.framework/Headers/qbrush.h:50,
                from /Library/Frameworks/QtGui.framework/Headers/qpalette.h:47,
                from /Library/Frameworks/QtGui.framework/Headers/qwidget.h:49,
                from /Library/Frameworks/QtGui.framework/Headers/QWidget:1,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/Qt/Chart/pqChartArea.h:41,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/Qt/Chart/pqChartArea.cxx:36:
/Library/Frameworks/QtGui.framework/Headers/qregion.h: In member function 'OpaqueRgnHandle* QRegion::handle(bool) const':
/Library/Frameworks/QtGui.framework/Headers/qregion.h:162: error: 'toQDRgn' was not declared in this scope
make[3]: *** [Qt/Chart/CMakeFiles/QtChart.dir/pqChartArea.o] Error 1
make[2]: *** [Qt/Chart/CMakeFiles/QtChart.dir/all] Error 2
make[1]: *** [Servers/ServerManager/CMakeFiles/HTMLDocumentation.dir/rule] Error 2
make: *** [HTMLDocumentation] Error 2
    Installing ParaView to /Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/platforms/darwinIntel64
disabled 'make install' for now, just use links
    ---
    Installation complete
    Set environment variables:

        export ParaView_INST_DIR=/Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1
        export ParaView_DIR=/Users/staldead/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/platforms/darwinIntel64
        export PV_PLUGIN_PATH=/Users/staldead/OpenFOAM/OpenFOAM-1.6.x/lib/darwinIntel64DPOpt
        export PATH=$ParaView_DIR/bin:$PATH
    ---
-- Replacing path hard links for $ParaView_DIR
-n    *.cmake:
-n #
...
-n #

-- Replacing path hard links for $ParaView_INST_DIR
-n    *.cmake:
-n #
...
-n #

done

Code:

Creating qmake. Please wait...
c++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/src/corelib/arch/generic -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/src/corelib/global -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/src/script -DQT_NO_PCRE -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_BUILD_QMAKE -DQT_NO_COMPRESS -I/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/mkspecs/darwin-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT  project.cpp
In file included from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/qglobal.h:1,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/../../src/corelib/tools/qalgorithms.h:47,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/qalgorithms.h:1,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/../../src/corelib/tools/qstringlist.h:47,
                from /Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/qstringlist.h:1,
                from project.h:47,
                from project.cpp:44:
/Users/staldead/OpenFOAM/ThirdParty-1.6.x/qt-x11-opensource-src-4.3.5/include/QtCore/../../src/corelib/global/qglobal.h:924:6: error: #error "This version of Mac OS X is unsupported"
make: *** [project.o] Error 1
make: *** No targets specified and no makefile found.  Stop.

real        0m0.004s
user        0m0.002s
sys        0m0.002s
make: *** No rule to make target `install'.  Stop.
    Finished building Qt-4.3.5.


gschaider March 30, 2010 09:01

I havn't checked, but I'm quite sure that Qt 4.3.5 is ancient history and won'T support 64 bit on MacOS. Where did you get the 4.6.2-version from? There have been issues with the binaries distributed by Trolltech in the past.

I use the version from MacPorts (the port is qt4-mac) without problems

Bernhard

Adrian April 8, 2010 11:59

Hi Bernhard

Thank you for your answer. I also used the Qt over MacPorts, but somehow it didnt want to work.
I am working now with ParaView 3.7.0 from http://www.ifdmavt.ethz.ch/education...foam/of-macosx
This seems to be the easiest way right now.

masuarez August 8, 2010 04:16

I have the exact same problem as Adrian above, but i'm using ParaView 3.8.0. I got QT 4.6 from ftp://ftp.trolltech.no/qt/source/ I was directed to this website from http://www.paraview.org/Wiki/ParaView:Build_And_Install

I just noticed that there is a QT 4.7... I have just downloaded and now working on installing ParaView 3.8 using the most current Qt. I'll keep you posted


All times are GMT -4. The time now is 13:22.