CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Conflict between OpenFOAM and NX Server (http://www.cfd-online.com/Forums/openfoam/74365-conflict-between-openfoam-nx-server.html)

MechE March 30, 2010 17:55

Conflict between OpenFOAM and NX Server
 
I am currently running OpenFOAM on a Fedora 12 64-bit computer in a remote location I followed the instructions and inputted the following:

. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc

and then:

. $HOME/.bashrc

I can run OpenFOAM fine when i am physically on the remote computer but once i go off-site and try to get into it using the NX Client the desktop appears black.

So; after many hours... I deleted the line . $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc from the .bashrc file and then . $HOME/.bashrc

miraculously afterward i used the NX Client and it connected right to the desktop. But i can't run the code :(

Is there a work around for using this OpenFOAM bashrc file??

MT

linnemann March 31, 2010 02:13

Hi

You could try creating an alias for OF in your $HOME/.bashrc file like so

Code:

alias OF=". $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc"
Then it will load all the OpenFOAM settings by running OF from the terminal.

MechE March 31, 2010 07:44

Do i have to run: . $HOME/.bashrc after i call OF in the terminal?

wyldckat March 31, 2010 08:42

Hello again MechE,

The script $HOME/.bashrc is always called when you start a new terminal/console. Now, if you have changed the script and want the changes to be applied, then you can either:
  • source it:
    Code:

    . $HOME/.bashrc
  • run the changes directly in the command line;
  • or open a new terminal/console.
As for the NX Server issue, hopefully, after you follow Linnemann's instructions, start a new terminal or source the .bashrc script, then verify if the NX Server hasn't gone blind. Then setup the OpenFOAM's environment by typing OF and hit return/enter on the desired terminal and voilá... it either goes dark or it works ;)

If it does goes dark again, then it's really weird! The only justification I can think of would be if you were running a single remote terminal without X windows (Gnome, KDE, etc...). The other idea, is if it goes black right after you launch Paraview/paraFoam...

Keep us posted on new developments ;)

Best regards,
Bruno

MechE April 9, 2010 16:21

Thank you very much for your help... I am now up and running!!

MT


All times are GMT -4. The time now is 16:56.